summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsirlucjan2017-04-20 17:17:33 +0200
committersirlucjan2017-04-20 17:17:33 +0200
commit75f6d43aca3eae289d23cea1d223dcc0a27c3809 (patch)
tree00a9f950a88cbf0949f8078c50d8a24676f6e8b5 /PKGBUILD
parentffdb256dfe40dddf543d7d5ad8d9f4d202f5206e (diff)
downloadaur-75f6d43aca3eae289d23cea1d223dcc0a27c3809.tar.gz
Bump to 4.10-series
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index daa9f7ad57a7..239b6de496b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,22 @@
pkgname=nvidia-lqx
pkgver=378.13
-_extramodules=extramodules-4.9-lqx
-pkgrel=1
+_extramodules=extramodules-4.10-lqx
+pkgrel=2
_pkgdesc="NVIDIA drivers for linux-lqx."
pkgdesc="$_pkgdesc"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-lqx>=4.9' 'linux-lqx<4.10' "nvidia-libgl" "nvidia-utils=${pkgver}")
-makedepends=('linux-lqx-headers>=4.9' 'linux-lqx-headers<4.10')
+depends=('linux-lqx>=4.10' 'linux-lqx<4.11' "nvidia-libgl" "nvidia-utils=${pkgver}")
+makedepends=('linux-lqx-headers>=4.10' 'linux-lqx-headers<4.11')
conflicts=('nvidia-304xx-lqx' 'nvidia-340xx-lqx')
license=('custom')
install=nvidia-lqx.install
options=(!strip)
+source=('kernel_4.10.patch')
source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+md5sums=('e81769b830b7a1e60c635e3bbe559f59')
md5sums_i686=('dd1077750af9a067739ec291fb24175f')
md5sums_x86_64=('fe4d25b19a780a690cafc8e3b7c0113f')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
@@ -26,6 +28,7 @@ md5sums_x86_64=('fe4d25b19a780a690cafc8e3b7c0113f')
prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
+ patch -Np1 --no-backup-if-mismatch -i ../kernel_4.10.patch
}
build() {