summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2024-03-04 08:34:11 -0300
committerDaniel Bermond2024-03-04 08:34:11 -0300
commitb308b33873c565fd6ac5c0e2e1368f11188481c8 (patch)
treea42f97ce766be4de7389e428f102911823f5b852 /PKGBUILD
parentea6b2dba8393b1d46490aa599e021acb570210dd (diff)
downloadaur-b308b33873c565fd6ac5c0e2e1368f11188481c8.tar.gz
Update patches and license. Add version in dkms configuration.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34cb900c06a7..5a85aebac3d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgbase=nvidia-open-git
pkgname=('nvidia-open-git' 'nvidia-open-dkms-git')
-pkgver=525.85.12.r0.g1dc88ff75
-pkgrel=2
+pkgver=550.54.14.r0.g476bd3453
+pkgrel=1
pkgdesc='NVIDIA open GPU kernel modules (git version)'
arch=('x86_64')
url='https://github.com/NVIDIA/open-gpu-kernel-modules/'
-license=('MIT' 'GPL2')
+license=('MIT' 'GPL-2.0-only')
makedepends=('git' 'linux-headers')
options=('!buildflags' '!lto' '!strip')
source=('git+https://github.com/NVIDIA/open-gpu-kernel-modules.git'
@@ -18,8 +18,8 @@ source=('git+https://github.com/NVIDIA/open-gpu-kernel-modules.git'
sha256sums=('SKIP'
'009724e2e07b7be589ba455f225a9742d88a3a29383f2f220cb830ef4c8b7aea'
'b0f62a78f749ff3a104197c12b6d885352adcf35fb5ecf00c4cd4c51b4195e45'
- '5916c0250a45a216f407f79fb2f44323eae0895804812c428baa98113afc1339'
- 'baa891c56747a4862f64f3259aebcaf24beade8d850a77468f92d4f9bbf6cd7f')
+ '15421d72aabc569c69762c77c7a37ad7be617f08e3c833318cecdeb5500e8ef4'
+ '71158935db9494bf8a18c34b29e2be19424ba09ce3017b9d9d7b6509f6090118')
prepare() {
patch -d open-gpu-kernel-modules -Np1 -i "${srcdir}/110-nvidia-open-change-dkms-conf.patch"
@@ -27,6 +27,8 @@ prepare() {
patch -d open-gpu-kernel-modules -Np1 -i "${srcdir}/130-nvidia-open-reproducible-build.patch"
patch -d open-gpu-kernel-modules -Np1 -i "${srcdir}/140-nvidia-open-gcc-sls.patch"
+ sed -i "s/__VERSION_STRING/${pkgver}/" open-gpu-kernel-modules/kernel-open/dkms.conf
+
[ -d dkms-src ] && rm -rf dkms-src
cp -af open-gpu-kernel-modules/kernel-open dkms-src
}