summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2020-07-05 21:48:34 +0000
committerDaniel Bermond2020-07-05 21:48:34 +0000
commit3256e3327bf784c9c21bb3147e60c4877a8ca1a5 (patch)
treedaf4bbaf110c3d3294f23ee6e0b6595df4b2b011 /PKGBUILD
parent19bbd02a83a9a685ef147f6a37c0419b56779898 (diff)
downloadaur-3256e3327bf784c9c21bb3147e60c4877a8ca1a5.tar.gz
Updated to version 10.0.26
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 9 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9325e2ffb845..7a09d93ebedc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
# NOTE:
# You need to download the SDK file from NVIDIA's website (registration required)
@@ -6,7 +6,7 @@
# https://developer.nvidia.com/nvidia-video-codec-sdk/
pkgname=nvidia-sdk
-pkgver=9.1.23
+pkgver=10.0.26
pkgrel=1
pkgdesc='NVIDIA Video Codec SDK (NVDECODE and NVENCODE APIs) (needs registration at upstream URL and manual download)'
arch=('any')
@@ -14,27 +14,16 @@ url='https://developer.nvidia.com/nvidia-video-codec-sdk/'
license=('custom')
makedepends=('poppler')
source=("local://Video_Codec_SDK_${pkgver}.zip")
-sha256sums=('26976a012920314f50af25e7914d3950d2cfb6cd7e4226d4643f4aa9c256d6e1')
+sha256sums=('67ff4543f93ad8ec1bc4ce2ef653b0778b94652597da9762a6e08f442dad5f45')
prepare() {
- cd "Video_Codec_SDK_${pkgver}"
-
- pdftotext -layout LicenseAgreement.pdf
+ pdftotext -layout "Video_Codec_SDK_${pkgver}/LicenseAgreement.pdf"
}
package() {
- cd "Video_Codec_SDK_${pkgver}"
-
- # encoder header
- install -D -m644 include/nvEncodeAPI.h -t "${pkgdir}/usr/include/${pkgname}"
-
- # decoder headers
- install -D -m644 include/cuviddec.h -t "${pkgdir}/usr/include/${pkgname}"
- install -D -m644 include/nvcuvid.h -t "${pkgdir}/usr/include/${pkgname}"
-
- # documentation
- install -D -m644 doc/* -t "${pkgdir}/usr/share/doc/${pkgname}"
-
- # license
- install -D -m644 LicenseAgreement.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "Video_Codec_SDK_${pkgver}/Interface/nvEncodeAPI.h" -t "${pkgdir}/usr/include/${pkgname}"
+ install -D -m644 "Video_Codec_SDK_${pkgver}/Interface/cuviddec.h" -t "${pkgdir}/usr/include/${pkgname}"
+ install -D -m644 "Video_Codec_SDK_${pkgver}/Interface/nvcuvid.h" -t "${pkgdir}/usr/include/${pkgname}"
+ install -D -m644 "Video_Codec_SDK_${pkgver}/Doc"/* -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -D -m644 "Video_Codec_SDK_${pkgver}/LicenseAgreement.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}