summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-04-03 16:35:38 +0000
committerDaniel Bermond2018-04-03 16:35:38 +0000
commit3f26379188ae6fb408f6ce816c09478aef83ccd9 (patch)
treea8a13759c1be8bdcedb63c1e21b392d550e9f0d0 /PKGBUILD
parent865bf6966690afe61b8d0e2a6fbb5883979ea194 (diff)
downloadaur-3f26379188ae6fb408f6ce816c09478aef83ccd9.tar.gz
Updated to version 8.1.24
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51526eb5b682..615d96ac05b7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,16 @@
# https://developer.nvidia.com/nvidia-video-codec-sdk/
pkgname=nvidia-sdk
-pkgver=8.0.14
+pkgver=8.1.24
pkgrel=1
pkgdesc="NVIDIA Video Codec SDK (NVDECODE and NVENCODE APIs) (needs registration at upstream URL and manual download)"
arch=('i686' 'x86_64')
url="https://developer.nvidia.com/nvidia-video-codec-sdk/"
license=('custom')
+makedepends=('poppler')
options=('!strip' 'staticlibs')
-source=("file://Video_Codec_SDK_${pkgver}.zip"
- 'LICENSE')
-sha256sums=('3dfff57702dd2ffad833d28390bdcd7367262588f86a471d4af0091de7e0db6c'
- '35c0656b536b2b0d0ea589f0b39e04589725f8b695d69cfffcba3b125e3c70e7')
+source=("file://Video_Codec_SDK_${pkgver}.zip")
+sha256sums=('578d038d9c151e80c03909791485d0cbc1f2deedab4b14d765e203c87a2f626e')
package() {
# directories creation
@@ -24,12 +23,12 @@ package() {
mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
# includes
- cd "Video_Codec_SDK_${pkgver}/Samples/common/inc"
+ cd "Video_Codec_SDK_${pkgver}/LegacySamples/common/inc"
install -m644 *.h "${pkgdir}/usr/include/${pkgname}"
install -m644 GL/*.h "${pkgdir}/usr/include/${pkgname}/GL"
# lib
- cd "${srcdir}/Video_Codec_SDK_${pkgver}/Samples/common/lib/linux/${CARCH}"
+ cd "${srcdir}/Video_Codec_SDK_${pkgver}/LegacySamples/common/lib/linux/${CARCH}"
install -D -m644 libGLEW.a "${pkgdir}/usr/lib/${pkgname}/libGLEW.a"
# documentation
@@ -37,5 +36,7 @@ package() {
install -m644 * "${pkgdir}/usr/share/doc/${pkgname}"
# license
- install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/Video_Codec_SDK_${pkgver}"
+ pdftotext -layout LicenseAgreement.pdf
+ install -D -m644 LicenseAgreement.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}