summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-05-08 15:59:52 -0300
committerDaniel Bermond2017-05-08 15:59:52 -0300
commitb78f4b721cae2320e69189a5ca4d6a78644ec045 (patch)
treee5a383131e3ee5ab2ea7afbdb21e12d183af8028 /PKGBUILD
parent67f5cb21366ce035ec23c085774b03aaf0d1765e (diff)
downloadaur-b78f4b721cae2320e69189a5ca4d6a78644ec045.tar.gz
White space and cosmetic changings
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD45
1 files changed, 22 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23ecb3f101aa..de62e18a3a0f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
-# NVIDIA Video Codec SDK
-# You need to download the SDK file from NVIDIA's website. (registration required)
+# NOTE:
+# You need to download the SDK file from NVIDIA's website (registration required)
# Download website:
# https://developer.nvidia.com/nvidia-video-codec-sdk/
pkgname=nvidia-sdk
pkgver=7.1.9
-pkgrel=1
+pkgrel=2
pkgdesc="NVIDIA Video Codec SDK (NVDECODE and NVENCODE APIs) (needs registration at upstream URL and manual download)"
arch=('i686' 'x86_64')
url="https://developer.nvidia.com/nvidia-video-codec-sdk/"
@@ -19,24 +19,23 @@ sha256sums=('6b1a3d822317bf7f075df404181cd770ae7bf414b27e069f74f4e914a8702710'
'0e574d8c44e23cbfe4ecde5b3d7629bdce64923d58a0d77b67117523b7360455')
package() {
- mkdir -p "${pkgdir}/usr/include/${pkgname}"
- mkdir -p "${pkgdir}/usr/include/${pkgname}/GL"
- mkdir -p "${pkgdir}/usr/lib/${pkgname}"
- mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
-
- # Includes
- cd "${srcdir}/Video_Codec_SDK_${pkgver}/Samples/common/inc"
- install -D -m644 *.h "${pkgdir}/usr/include/${pkgname}"
- install -D -m644 ./GL/*.h "${pkgdir}/usr/include/${pkgname}/GL"
-
- # Lib
- cd "${srcdir}/Video_Codec_SDK_${pkgver}/Samples/common/lib/linux/${CARCH}"
- install -D -m644 libGLEW.a "${pkgdir}/usr/lib/${pkgname}/libGLEW.a"
-
- # Documentation
- cd "${srcdir}/Video_Codec_SDK_${pkgver}/doc"
- install -D -m644 * "${pkgdir}/usr/share/doc/${pkgname}"
-
- # License
- install -D -m644 "$srcdir"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # directories creation
+ mkdir -p "${pkgdir}/usr/include/${pkgname}/GL"
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # includes
+ cd "Video_Codec_SDK_${pkgver}/Samples/common/inc"
+ install -m644 *.h "${pkgdir}/usr/include/${pkgname}"
+ install -m644 GL/*.h "${pkgdir}/usr/include/${pkgname}/GL"
+
+ # lib
+ cd "${srcdir}/Video_Codec_SDK_${pkgver}/Samples/common/lib/linux/${CARCH}"
+ install -D -m644 libGLEW.a "${pkgdir}/usr/lib/${pkgname}/libGLEW.a"
+
+ # documentation
+ cd "${srcdir}/Video_Codec_SDK_${pkgver}/doc"
+ install -m644 * "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # license
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}