summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBermond2016-07-27 21:48:03 -0300
committerBermond2016-07-27 21:48:03 -0300
commitcc345587d9391af708a85fb3f1c341368bd61743 (patch)
tree45d10bdeecb260a328ac2c612f0cce59cf5d7b70 /PKGBUILD
parent954e9c3fdbfeb6c1bd68d24b350f38be2dde3f7d (diff)
downloadaur-cc345587d9391af708a85fb3f1c341368bd61743.tar.gz
Updated to version 7.0.1
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba4de17ad8e0..25d3f5c04aa7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,41 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
-# NVIDIA Video Codec SDK (NVENC API and NVCUVID API)
+# NVIDIA Video Codec SDK
+# You need to download the SDK file from NVIDIA's website. (registration required)
+# Download website:
+# https://developer.nvidia.com/nvidia-video-codec-sdk/
pkgname=nvidia-sdk
-pkgver=6.0.1
-_srcurlver="$(echo ${pkgver} | tr -d '.')"
+pkgver=7.0.1
pkgrel=1
-pkgdesc="NVIDIA Video Codec SDK (NVENC API and NVCUVID API)"
+pkgdesc="NVIDIA Video Codec SDK (NVENCODE API and NVDECODE API)"
arch=('any')
url="https://developer.nvidia.com/nvidia-video-codec-sdk/"
license=('custom')
-provides=('nvenc-api')
-conflicts=('nvenc-api')
-source=(nvidia_video_sdk_"$pkgver".zip::"https://developer.nvidia.com/video-sdk-${_srcurlver}"
+source=("file://Video_Codec_SDK_${pkgver}.zip"
'LICENSE')
-sha256sums=('05227ee4015dc9bdf52b4fe8b3ba5a077d80962f35fa3b76d25288adb1dd0122'
- 'b23d2f61684603966be6eb94db58fe11d2594c3328a72aa005acda1d48596be8')
+sha256sums=('03acd43f04d72b2bc3bdcfd8d46c8f0e12be2aa7ace871589232a31269d08c86'
+ '04881e31bd6997cea2d7ac1e9db4f26954230754bf1809333d8d0091a18d21ae')
package() {
- cd "${srcdir}/nvidia_video_sdk_${pkgver}/Samples/common/inc"
-
mkdir -p "${pkgdir}/usr/include/${pkgname}"
mkdir -p "${pkgdir}/usr/include/${pkgname}/GL"
+ mkdir -p "${pkgdir}/usr/lib/${pkgname}"
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # Includes
+ cd "${srcdir}/Video_Codec_SDK_${pkgver}/Samples/common/inc"
+ install -D -m644 *.h "${pkgdir}/usr/include/${pkgname}"
+ install -D -m644 ./GL/*.h "${pkgdir}/usr/include/${pkgname}/GL"
- install -D -m644 *.h "${pkgdir}/usr/include/${pkgname}"
+ # Lib
+ cd "${srcdir}/Video_Codec_SDK_${pkgver}/Samples/common/lib/linux/${CARCH}"
+ install -D -m644 libGLEW.a "${pkgdir}/usr/lib/${pkgname}/libGLEW.a"
- cd GL
- install -D -m644 *.h "${pkgdir}/usr/include/${pkgname}/GL"
+ # Documentation
+ cd "${srcdir}/Video_Codec_SDK_${pkgver}/doc"
+ install -D -m644 * "${pkgdir}/usr/share/doc/${pkgname}"
+ # License
install -D -m644 "$srcdir"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}