summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwhoseos2017-06-21 00:32:53 +0200
committerwhoseos2017-06-21 00:36:15 +0200
commitb982b01a0f17ea32ac2c687241945fdecf059e29 (patch)
tree3eab796350b5688fab431c941d692f5b4a56991f /PKGBUILD
parent208afbfd0b1922424409b5a0415a0b5abdfb71c5 (diff)
downloadaur-b982b01a0f17ea32ac2c687241945fdecf059e29.tar.gz
Merge changes from nvidia-beta and update to latest vulkan developer driver 381.26.03
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88f1d34b335e..817989bb2935 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Based on [aur]'s nvidia-beta: https://aur.archlinux.org/packages/nvidia-beta/
pkgname=nvidia-vulkan-developer-beta
-pkgver=375.27.15
-pkgrel=2
+pkgver=381.26.03
+pkgrel=1
pkgdesc="NVIDIA driver for Arch's official 'linux' package (vulkan developer beta version)"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
@@ -18,15 +18,17 @@ install=$pkgname.install
# Installer name
case "$CARCH" in
- i686) _pkg="linux-375271532bit"; _pkg_dir="NVIDIA-Linux-x86_64-$pkgver" ;;
- x86_64) _pkg="linux-3752715-64-bit"; _pkg_dir="NVIDIA-Linux-x86_64-$pkgver" ;;
+ i686) _pkg="${pkgver//./}-linux-32bit"; _pkg_dir="NVIDIA-Linux-x86-$pkgver" ;;
+ x86_64) _pkg="${pkgver//./}-linux-64bit"; _pkg_dir="NVIDIA-Linux-x86_64-$pkgver" ;;
esac
# Source
-source_i686=("https://developer.nvidia.com/linux-3752715-32-bit")
-source_x86_64=("https://developer.nvidia.com/linux-3752715-64-bit")
-md5sums_i686=('0a2e0a05ed1f5babba47b5d301a4e8fa')
-md5sums_x86_64=('a1f786592c91c97d654fec4e84e31e56')
+source=('linux-4.11.patch')
+source_i686=("https://developer.nvidia.com/${pkgver//./}-linux-32bit")
+source_x86_64=("https://developer.nvidia.com/${pkgver//./}-linux-64bit")
+md5sums=('cc8941b6898d9daa0fb67371f57a56b6')
+md5sums_i686=('07d6373f9d2672afacf11be1060bebb6')
+md5sums_x86_64=('b41bddbe1a613f3c3a07591a276f3202')
# Auto-detect patches (e.g. linux-4.1.patch)
for _patch in $(find "$startdir" -maxdepth 1 -name '*.patch' -printf "%f\n"); do
@@ -57,7 +59,7 @@ prepare() {
# Check version
if (( $(vercmp $_kernel $_major_patch) >= 0 )); then
msg2 "Applying $_patch..."
- patch -p0 -i "$_patch"
+ patch -p1 -i "$_patch"
fi
done
}