summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwhoseos2017-03-12 19:00:04 +0100
committerwhoseos2017-03-12 19:00:04 +0100
commitfc7f508f9c9af08a57fd2a06c5f531596ffa9e69 (patch)
treed549fc5a426765bc7c2e63189352cfd6c443c6e5 /PKGBUILD
parentf3b5ba97eef6d1b4fa0102cc894c4f43c6e32c62 (diff)
downloadaur-fc7f508f9c9af08a57fd2a06c5f531596ffa9e69.tar.gz
Update to latest version and switch to lts kernel as dependency
Unfortunately the driver does not compile with kernel 4.10 and I did not find a patch for this specific driver version yet. The package will be set back to linux as dependency as soon as I find a patch or a new release with fixed sources.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27aa3b8a1fcf..f3a1f3314412 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Based on [aur]'s nvidia-beta: https://aur.archlinux.org/packages/nvidia-beta/
pkgname=nvidia-vulkan-developer-beta
-pkgver=375.27.13
+pkgver=375.27.14
pkgrel=1
pkgdesc="NVIDIA driver for Arch's official 'linux' package (vulkan developer beta version)"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
license=('custom:NVIDIA')
-depends=('linux' "nvidia-utils-vulkan-developer-beta>=$pkgver" 'libgl')
-makedepends=('linux-headers')
+depends=('linux-lts' "nvidia-utils-vulkan-developer-beta>=$pkgver" 'libgl')
+makedepends=('linux-lts-headers')
provides=("nvidia=$pkgver")
conflicts=('nvidia-96xx' 'nvidia-173xx' 'nvidia')
options=('!strip')
@@ -18,16 +18,16 @@ install=$pkgname.install
# Installer name
case "$CARCH" in
- i686) _pkg="linux-3752713-32-bit"; _pkg_dir="NVIDIA-Linux-x86_64-$pkgver" ;;
- x86_64) _pkg="linux-3752713-64-bit"; _pkg_dir="NVIDIA-Linux-x86_64-$pkgver" ;;
+ i686) _pkg="linux-3752714-32-bit"; _pkg_dir="NVIDIA-Linux-x86_64-$pkgver" ;;
+ x86_64) _pkg="linux-3752714-64-bit"; _pkg_dir="NVIDIA-Linux-x86_64-$pkgver" ;;
esac
# Source
#source=('linux-4.8.patch')
-source_i686=("https://developer.nvidia.com/linux-3752713-32-bit")
-source_x86_64=("https://developer.nvidia.com/linux-3752713-64-bit")
-md5sums_i686=('e1f0620ef6cae6a4158dce72b1e67db7')
-md5sums_x86_64=('8c02c850ca837fe25fac0a45f8a15b2c')
+source_i686=("https://developer.nvidia.com/linux-3752714-32-bit")
+source_x86_64=("https://developer.nvidia.com/linux-3752714-64-bit")
+md5sums_i686=('9f97042234b2ca4d4b63c3ddc384b4a7')
+md5sums_x86_64=('a8b5683411bb968f616654cd4bae2e56')
# Auto-detect patches (e.g. linux-4.1.patch)
for _patch in $(find "$startdir" -maxdepth 1 -name '*.patch' -printf "%f\n"); do
@@ -52,7 +52,7 @@ prepare() {
# Loop patches
for _patch in $(ls "$srcdir"/*.patch 2>/dev/null); do
# Version variables
- _kernel=$(cat /usr/lib/modules/extramodules-*-ARCH/version)
+ _kernel=$(cat /usr/lib/modules/extramodules-*-lts/version)
_major_patch=$(echo $_patch | grep -Po "\d+\.\d+")
# Check version
@@ -65,8 +65,8 @@ prepare() {
build() {
# Version of 'linux'
- _major=$(pacman -Q linux | grep -Po "\d+\.\d+")
- _extramodules=extramodules-$_major-ARCH
+ _major=$(pacman -Q linux-lts | grep -Po "\d+\.\d+")
+ _extramodules=extramodules-$_major-lts
_kernel=$(cat /usr/lib/modules/$_extramodules/version)
# Build module
@@ -77,8 +77,8 @@ build() {
package() {
# Version of 'linux'
- _major=$(pacman -Q linux | grep -Po "\d+\.\d+")
- _extramodules=extramodules-$_major-ARCH
+ _major=$(pacman -Q linux-lts | grep -Po "\d+\.\d+")
+ _extramodules=extramodules-$_major-lts
# Install
install -Dm644 $_pkg_dir/kernel/nvidia.ko \