summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpiotr2022-02-08 00:07:39 +0100
committerpiotr2022-02-08 00:07:39 +0100
commit063d827ed5bfd5f1ba547a3bfe1d433568891bfe (patch)
tree8e6572c662129539e53a533dd259f73a50e8bf4e /PKGBUILD
downloadaur-063d827ed5bfd5f1ba547a3bfe1d433568891bfe.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8508d276fb20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
+pkgname=('nwg-shell')
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="nwg-shell meta-package and installer"
+arch=('x86_64')
+url="https://github.com/nwg-piotr/nwg-shell"
+license=('MIT')
+depends=('python' 'sway' 'grim' 'slurp' 'swayidle' 'swaylock' 'swappy' 'wl-clipboard' 'jq'
+ 'lxappearance' 'foot' 'wlsunset' 'wdisplays' 'swaync' 'python-geopy' 'python-dasbus'
+ 'azote' 'autotiling' 'nwg-panel' 'nwg-wrapper' 'nwg-bar' 'nwg-dock' 'nwg-drawer'
+ 'nwg-menu' 'gopsuinfo' 'nwg-shell-config')
+optdepends=('xorg-xwayland: for X clients'
+ 'libappindicator-gtk3: for tray status icon')
+makedepends=('python-setuptools' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/nwg-piotr/nwg-shell/archive/v"$pkgver".tar.gz")
+
+md5sums=('SKIP')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -t "$pkgdir"/usr/share/backgrounds nwg-shell.jpg
+}