summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Heinrich2017-07-26 23:22:54 +0200
committerJonas Heinrich2017-07-26 23:22:54 +0200
commitd47bf24a765b6eb97785e67ef51574c3dca9e46d (patch)
tree2c781b5f0fa1d7cf8e5dfdb057a164ad578dfd2c /PKGBUILD
parentd69882d63d4c6e1f7d5d64910e92be638fe0d2c0 (diff)
downloadaur-d47bf24a765b6eb97785e67ef51574c3dca9e46d.tar.gz
fixed gclient permission issues
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa8553177699..6e5f01a0fb7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,10 @@
# Contributor: Jonas Heinrich <onny@project-insanity.org>
# ToDo: Enable propretary codec
-# Bugs: Permission issue, wants to write to /opt/depot_tools/external_bin chmod -R a+w :/
pkgname=nwjs
pkgver=0.24.0
-pkgrel=2
+pkgrel=3
pkgdesc="node-webkit is an app runtime based on Chromium and node.js"
arch=("i686" "x86_64")
url="https://nwjs.io/"
@@ -36,6 +35,9 @@ prepare() {
# Removing references to git version in build config,
# since we will use the stable source tarball
sed -i '/\"\:commit_id\"/d' "nw.js-nw-v${pkgver}/content/nw/BUILD.gn"
+
+ # Local copy of depot_tools to manage temporary write permissions
+ cp -r /opt/depot_tools .
}
build() {
@@ -43,7 +45,7 @@ build() {
mkdir -p nwjs
cd nwjs
- export PATH="/opt/depot_tools:$PATH"
+ export PATH="${srcdir}/depot_tools:$PATH"
export PATH="${srcdir}/path:$PATH"
export GYP_DEFINES="target_arch=x64"