summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsurefire2017-06-15 19:52:25 +0300
committersurefire2017-06-15 19:52:25 +0300
commitb037e9a93ab3ea32f462f505d8c10499c5a57757 (patch)
tree58d3ce1765bc069b16ab2d15d64c28dfd72250fe /PKGBUILD
parent9969ca2e332e33e09d7b80787bb51c54c8f79cab (diff)
downloadaur-b037e9a93ab3ea32f462f505d8c10499c5a57757.tar.gz
upgpkg: nxt 1.11.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD84
1 files changed, 48 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0bb3c3211fc..8960963b8c37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,69 @@
# Maintainer: David Parrish <daveparrish@gmail.com>
pkgname=nxt-git
-pkgver=1.5.12.r5.g5bbafe1
+pkgver=1.11.5+0+gfc25fd5a2
pkgrel=1
-pkgdesc="The Nxt Reference Software Client for use with the Nxt Cryptocurrency."
+pkgdesc="The Nxt Reference Software Client for use with the Nxt Cryptocurrency"
arch=('any')
url="http://nxt.org"
license=('MIT' 'GPL' 'MPL' 'APACHE')
-depends=('bash' 'java-runtime-openjdk=8')
-makedepends=('java-environment-openjdk=8')
-optdepends=('flashplugin: NRS clipboard support'
- 'libnotify: NRS startup error notification'
- 'tor: route NXT traffic through Tor')
-source=("${pkgname}::git+https://bitbucket.org/JeanLucPicard/nxt.git"
- "nxt.service"
- "nxt-tor.service"
- "nxt.install"
- "nrs.sh"
- "nrs.desktop")
+depends=('java-runtime>=8' 'systemd')
+makedepends=('java-environment>=8')
+source=('git+https://bitbucket.org/JeanLucPicard/nxt.git'
+ 'logging.properties'
+ 'nxt.properties'
+ 'nxt.sysusers'
+ 'nxt.tmpfiles'
+ 'nxt.service'
+ 'nxt.desktop'
+ 'nxt.sh')
+backup=('etc/nxt/nxt.properties'
+ 'etc/nxt/logging.properties')
sha256sums=('SKIP'
- '293bf1e313677f769e4a12e6e0f78bbd58c796ebe7c34528ba50cd73bbea15a7'
- '87a725d1e2cf5af3554dd8d2775c94a952bc27313287777f0ca8984644f0d9b4'
- 'b7575397d7dd19e9b1bab75e21a433f3bdc98279ad822fe57235b830c062abca'
- 'b0429b9fb91f1b7ecd6bac2f93b36e0a0344efa21052fd5b1742067e11ba89e5'
- '8381f120b645cca9079b5e958a8917326f71b55f031f15df3324703377638eee')
-install='nxt.install'
+ 'e00b9e5a605653faec8a4582ba004eff54c3692f60dc5a8c13c98119041195b1'
+ 'a65abe20dcec9ab4e7f39b5f16daee3e10a0b93dd78cadea47d45289ea145cbf'
+ 'd73213fe300346c548e991af0797b23b3c608e803f741cd0ae89d3bb0549bfe3'
+ '2f4775688213f0948364f1594162c12a6ec865501f7434847ce9bb7c73b11c59'
+ '9c3ba3fff584e4baae3d9af88aa62418fd701094d2256e6e687300ce35b1f6f8'
+ '9c5cd343af10ba63d024280e79453fa92a1c0864b47c77020eaa86fc316f5661'
+ 'c3beaaf62b9d499e023426d4206d8eb775d7dcf6f7b005b3bb34b12d64d9c1af')
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd nxt
+ git describe --long --tags | sed 's/-/+/g; s/^v//'
}
build() {
- cd "${pkgname}"
- ./compile.sh
+ cd nxt
+
+ mkdir classes
+ shopt -s globstar
+ javac -encoding utf8 -sourcepath src/java/nxt -classpath "lib/*:classes" -d classes src/java/nxt/**/*.java
+ jar cf nxt.jar -C classes .
}
package() {
- # Copy everything to /opt/nxt
- install -dm755 "$pkgdir/opt/nxt"
- cp -r "${pkgname}"/* "$pkgdir"/opt/nxt/
+ cd nxt
+
+ install -d "$pkgdir/usr/share/java/nxt"
+ cp -rt "$pkgdir/usr/share/java/nxt" nxt.jar lib conf addons
+ rm -rf "$pkgdir/usr/share/java/nxt/"{addons/src,conf/.gitignore}
+
+ install -d "$pkgdir/usr/share/nxt"
+ cp -rt "$pkgdir/usr/share/nxt" ./html
+
+ install -Dm644 -t "$pkgdir/etc/nxt" ../{nxt,logging}.properties
# Service files
- install -Dm644 nxt.service "$pkgdir/usr/lib/systemd/system/nxt.service"
- install -Dm644 nxt-tor.service "$pkgdir/usr/lib/systemd/system/nxt-tor.service"
+ install -Dm644 ../nxt.service "$pkgdir/usr/lib/systemd/system/nxt.service"
+ install -Dm644 ../nxt.sysusers "$pkgdir/usr/lib/sysusers.d/nxt.conf"
+ install -Dm644 ../nxt.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/nxt.conf"
+
+ # Desktop files
+ install -Dm644 html/www/img/nxt_logo.png "${pkgdir}/usr/share/pixmaps/nxt.png"
+ install -Dm644 ../nxt.desktop "${pkgdir}/usr/share/applications/nxt.desktop"
+ install -Dm755 ../nxt.sh "$pkgdir/usr/bin/nxt"
# License files
- install -Dm644 "${pkgname}/COPYING.txt" "$pkgdir/usr/share/licenses/nxt/COPYING.txt"
- install -Dm644 "${pkgname}/3RD-PARTY-LICENSES.txt" "$pkgdir/usr/share/licenses/nxt/3RD-PARTY-LICENSES.txt"
- install -Dm644 "${pkgname}/LICENSE.txt" "$pkgdir/usr/share/licenses/nxt/LICENSES.txt"
-
- # NRS shortcut
- install -Dm644 "${pkgname}/html/nrs/icon.png" "${pkgdir}/usr/share/pixmaps/nrs.png"
- install -Dm644 nrs.desktop "${pkgdir}/usr/share/applications/nrs.desktop"
- install -Dm755 nrs.sh "$pkgdir/usr/bin/nrs"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" ./{COPYING,3RD-PARTY-LICENSES,LICENSE}.txt
}