summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcrabvk2022-11-16 21:12:31 +0500
committercrabvk2022-11-16 21:12:31 +0500
commit9c1e10a26563318e775dc37c76391cd80cc6b7a8 (patch)
treeeb9e63d9c539da72eb3582b68e8ca4e127c9c1da /PKGBUILD
parentc22fa5125c0a84d819fb7ed79e0ecbc757f1ff0a (diff)
downloadaur-9c1e10a26563318e775dc37c76391cd80cc6b7a8.tar.gz
Bump version to 1.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e4368972d58..4bb6b19a692d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vyacheslav Konovalov <🦀vk@protonmail.com>
pkgname=nym-wallet
-pkgver=1.0.9
+pkgver=1.1.0
pkgrel=1
pkgdesc='The next generation of privacy infrastructure (Nym Wallet)'
arch=('x86_64')
@@ -9,17 +9,19 @@ url='https://nymtech.net/'
license=('MIT')
depends=('openssl' 'pango' 'gdk-pixbuf2' 'webkit2gtk' 'librsvg' 'libbsd')
optdepends=('libappindicator-gtk3: system tray support')
-makedepends=('cargo' 'nodejs' 'npm' 'yarn' 'patchelf')
-source=("https://github.com/nymtech/nym/archive/refs/tags/nym-wallet-v$pkgver.tar.gz")
-sha512sums=('191d6e9848dacaa9cbb6a4ec26776d509981408b42028381138f9a1cb1904dbcc5da2fe68f349e8fd112ebde808ba4c566f83db257e3cb0317d8ac077db19fc5')
-_datadir="nym-wallet/target/release/bundle/deb/nym-wallet_${pkgver}_amd64/data"
+makedepends=('git' 'cargo' 'nodejs' 'npm' 'yarn' 'patchelf')
+source=()
+sha512sums=()
+_datadir="src-tauri/target/release/bundle/deb/nym-wallet_${pkgver}_amd64/data"
prepare() {
- sed -ri 's/"targets": .+,/"targets": ["deb"],/' nym-nym-wallet-v$pkgver/nym-wallet/src-tauri/tauri.conf.json
+ # NOTE: Build process requires full git repo
+ git clone https://github.com/nymtech/nym.git -b v$pkgver
+ sed -ri 's/"targets": .+,/"targets": ["deb"],/' nym/nym-wallet/src-tauri/tauri.conf.json
}
build() {
- cd nym-nym-wallet-v$pkgver/nym-wallet
+ cd nym/nym-wallet
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
@@ -34,8 +36,8 @@ build() {
}
package() {
- cd nym-nym-wallet-v$pkgver
+ cd nym
- cp -r "$_datadir/usr" "$pkgdir/"
+ cp -r "nym-wallet/$_datadir/usr" "$pkgdir/"
install -Dm644 LICENSES/MIT.txt "$pkgdir/usr/share/licenses/nym-wallet/LICENSE"
}