summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornyorain2018-03-20 16:19:29 +0100
committernyorain2018-03-20 16:19:29 +0100
commit86abeb5bc7817098c1183e8b7ece9ef4fe79874b (patch)
treeca02ea50db415c03a4ebfb19e6e55955f2e8c8e4 /PKGBUILD
parent74d129ced8779c3444435072d35f99cef2e50a1b (diff)
downloadaur-nytl-git.tar.gz
Update to meson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d515b1cfd99..0966b7f716ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: nyorain <nyorain at gmail dot com>
-pkgname=nytl-git
-pkgver=v0.3.alpha.r1.832e271
+pkgname=nytl-git
+pkgver=v0.5.r9.0916d47
pkgrel=1
pkgdesc="C++17 header-only utility library"
arch=('any')
@@ -8,7 +8,7 @@ url="https://github.com/nyorain/nytl"
license=('Boost')
groups=()
depends=()
-makedepends=('git' 'cmake' 'gcc')
+makedepends=('git' 'meson' 'gcc' 'ninja')
provides=()
conflicts=()
replaces=()
@@ -26,17 +26,17 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
- rm -rf build && mkdir build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ rm -rf build
+ meson --prefix=/usr build
}
build() {
cd "$srcdir/${pkgname%-git}/build"
- make
+ ninja
}
package() {
cd "$srcdir/${pkgname%-git}"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- make -C build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" ninja -C build install
}