summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-06-10 17:58:56 +0200
committerGoliathLabs2020-06-10 17:58:56 +0200
commitf5118be8a7d5198f99b2535c66a8ef056b2e3334 (patch)
tree54dc2cc972facdb650d3fc46282f017ef35c9b6a /PKGBUILD
downloadaur-f5118be8a7d5198f99b2535c66a8ef056b2e3334.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dcc674d78ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Cillian Berragan <cjberragan@gmail.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=nyxt-browser
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Keyboard-oriented, Common Lisp extensible web-browser"
+arch=('i686' 'x86_64')
+url="https://nyxt.atlas.engineer"
+license=('custom:BSD')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/atlas-engineer/nyxt/archive/$pkgver.tar.gz")
+sha512sums=('a5394b2a7177c8472d5029c1cb040aa3b2445f918a31e4d36cfc55b53154e9659ae4bae0a9bdf26639e803968c99206e1096e1cfb4bbd9a4c2d11ce609ed804c')
+
+# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
+makedepends=('sbcl' 'cl-asdf')
+depends=('webkit2gtk' 'sqlite' 'glib-networking' 'gsettings-desktop-schemas' 'libfixposix')
+optdepends=('gstreamer: for HTML5 audio/video'
+ 'gst-plugins-base: for HTML5 audio/video'
+ 'gst-plugins-good: for HTML5 audio/video'
+ 'gst-plugins-bad: for HTML5 audio/video'
+ 'gst-plugins-ugly: for HTML5 audio/video')
+# Binary will not run otherwise.
+options=('!strip' '!makeflags')
+
+build() {
+ cd ${pkgname%-browser}-$pkgver
+ make all
+}
+
+package() {
+ cd ${pkgname%-browser}-$pkgver
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}