summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Webster2018-01-15 12:14:21 -0800
committerDonald Webster2018-01-15 12:20:07 -0800
commit06c9d3ed4f1838a22b3f3418acdfbc3de98d1ce6 (patch)
tree62c6398d507f5b669293fe714eb412b7c0819b31 /PKGBUILD
parent99ca03d5b16ee74eb6a859c1d6bcd6214bf3d6c8 (diff)
downloadaur-06c9d3ed4f1838a22b3f3418acdfbc3de98d1ce6.tar.gz
Use python wrapper for expanded compatibility.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab0f3270f7e5..a75537313b8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
# Maintainer: Daniel Egeberg <daniel.egeberg@gmail.com>
pkgname="nzbhydra2"
pkgver=1.0.18
-pkgrel=1
+pkgrel=2
pkgdesc="Meta search for NZB indexers"
arch=('any')
url="https://github.com/theotherp/nzbhydra2"
license=('Apache')
-depends=('java-runtime-headless>=8')
-conflicts=('nzbhydra2-git')
+depends=('python2' 'java-runtime-headless>=8')
install='nzbhydra2.install'
source=("https://github.com/theotherp/nzbhydra2/releases/download/v${pkgver}/${pkgname}-${pkgver}-linux.zip"
+ "https://raw.githubusercontent.com/theotherp/nzbhydra2/master/other/wrapper/nzbhydra2wrapper.py"
'nzbhydra2.service'
'nzbhydra2.install'
'nzbhydra2.sysusers')
sha256sums=('d7c04f325760ecc0b8b52b9d88c0721d73e5967647e8e1c8becffcd67ebb94c6'
- '53cf695a8f03ab9c12754be6460dead8225b3a012f0f26675cead846521aeee1'
+ '07fe26612eed64a1c64704e963d834fdd52435fd37470325f196cab6f464c3a9'
+ '8c864fa865c92a6e0182f4dd3d4032ad85f09d021444cca217efafecbeff33c3'
'355dafa76d39c42f0a449080b2fe3673536e409da3f3b6c89f03c09dd303438c'
'8f91eb4f98f7f5c11590b29b1394dfa7ca62ad115feeac4f402c9ac094fb925a')
@@ -24,8 +25,10 @@ package() {
install -d -m 755 "${pkgdir}/usr/lib/nzbhydra2"
cd "${srcdir}"
- chmod +x nzbhydra2 downloaderScripts/*.py
- cp -dpr --no-preserve=ownership downloaderScripts lib nzbhydra2 readme.md "${pkgdir}/usr/lib/nzbhydra2"
+ chmod +x nzbhydra2
+ cp -dpr --no-preserve=ownership lib nzbhydra2 readme.md "${pkgdir}/usr/lib/nzbhydra2"
+
+ install -D -m 644 "${srcdir}/nzbhydra2wrapper.py" "${pkgdir}/usr/lib/nzbhydra2"
install -d -m 755 "${pkgdir}/var/lib/nzbhydra2"