summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-11-19 15:33:43 +0100
committerAlexander F. Rødseth2019-11-19 15:33:43 +0100
commit205fc693a794d103a03153d66abb036898626135 (patch)
tree69f26a77c4896e51724bac2a51ebf47e8015e7ba /PKGBUILD
parentdee645221e84215974b201ab781cffcf09d9b219 (diff)
downloadaur-205fc693a794d103a03153d66abb036898626135.tar.gz
New release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e49f1465548..6dc53bd1ebc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=o
-pkgver=2.8.0
+pkgver=2.9.0
pkgrel=1
-pkgdesc='Small, fast and limited text editor'
+pkgdesc='Small, fast and VT100-compatible text editor'
arch=(x86_64)
url='https://github.com/xyproto/o'
license=(BSD)
-makedepends=(git go)
+makedepends=(git go upx)
source=("git+$url#tag=$pkgver")
sha256sums=('SKIP')
build() {
cd "$pkgname"
+
+ # Using gccgo gives a smaller size, but forces AUR users to juggle between go and gccgo, which is unfortunate
#go build -buildmode=pie -gccgoflags="-s -w $LDFLAGS"
+
go build -buildmode=pie -gcflags="all=-trimpath=$PWD" -asmflags "all=-trimpath=$PWD" -ldflags "-s -w -extldflags $LDFLAGS"
+ upx o
}
package() {