summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2020-05-28 19:47:20 +0200
committerAlexander F. Rødseth2020-05-28 19:47:20 +0200
commit579d781f7101e7baa67cda6262ba6eafb07eef22 (patch)
tree91807b70c7efaddf3204b603b02532559d78d60d /PKGBUILD
parenta044b72113011e913b05922ee398241c0cef2f91 (diff)
downloadaur-579d781f7101e7baa67cda6262ba6eafb07eef22.tar.gz
Add optdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c331c56baa76..ad5637c2f2e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=o
pkgver=2.29.5
-pkgrel=1
+pkgrel=2
pkgdesc='Small, fast and VT100-compatible text editor'
arch=(x86_64)
url='https://github.com/xyproto/o'
@@ -11,13 +11,25 @@ makedepends=(git go-pie)
source=("git+$url#commit=07d440ec0a50122379b6dbd8f6a88961fbb35bfb") # tag: 2.29.5
sha256sums=('SKIP')
options=(!strip)
+optdepends=('cxx: for compiling C++'
+ 'brittany: for formatting Haskell'
+ 'clang: for formatting C++ code with clang-format'
+ 'rustup: for compiling and formatting Rust'
+ 'zig: for compiling and formatting Zig'
+ 'v: for compiling and formatting V'
+ 'ghc: for compiling Haskell'
+ 'ocaml: for compiling and formatting OCaml'
+ 'autopep8: for formatting Python'
+ 'scdoc: for writing man pages'
+ 'asciidoctor: for writing man pages'
+ 'pandoc: for exporting Markdown to PDF'
+ 'guessica: for updating PKGBUILD files')
build() {
cd $pkgname
# Using gccgo and upx gives a smaller size
#go build -buildmode=pie -gccgoflags="-s -w $LDFLAGS" && upx o
-
go build -buildmode=pie -gcflags="all=-trimpath=$PWD" -asmflags "all=-trimpath=$PWD" -ldflags "-s -w -extldflags $LDFLAGS"
}