summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2020-04-14 21:08:20 +0200
committerAlexander F. Rødseth2020-04-14 21:08:20 +0200
commitab3f48f68f1b6e2d9879609ceb335b819a14bdb0 (patch)
treedda4e6b6b2b20f0e55f44f20b5e3d06a45a36be3 /PKGBUILD
parent514b8efc3890d0e5f38c599bcd2b326d9779a1b4 (diff)
downloadaur-ab3f48f68f1b6e2d9879609ceb335b819a14bdb0.tar.gz
New release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 713c11c435b9..ee3529ab9516 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=o
-pkgver=2.15.3
+pkgver=2.23.0
pkgrel=1
pkgdesc='Small, fast and VT100-compatible text editor'
arch=(x86_64)
url='https://github.com/xyproto/o'
license=(BSD)
-makedepends=(git go-pie upx)
-source=("git+$url#tag=$pkgver")
+makedepends=(git go-pie)
+source=("git+$url#commit=40996ac65f14cdb8b41f62b1f331a1a60ab0421e") # tag: 2.23.0
sha256sums=('SKIP')
options=(!strip)
build() {
cd "$pkgname"
- # Using gccgo gives a smaller size, but forces AUR users to juggle between go and gccgo, which is unfortunate
- #go build -buildmode=pie -gccgoflags="-s -w $LDFLAGS"
+ # Using gccgo + upx gives a smaller size
+ #go build -buildmode=pie -gccgoflags="-s -w $LDFLAGS" && upx o
go build -buildmode=pie -gcflags="all=-trimpath=$PWD" -asmflags "all=-trimpath=$PWD" -ldflags "-s -w -extldflags $LDFLAGS"
- upx o
}
package() {
install -Dm755 $pkgname/o "$pkgdir/usr/bin/o"
install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 $pkgname/o.1 "$pkgdir/usr/share/man/man1/o.1"
}
# vim: ts=2 sw=2 et: