summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2020-08-11 23:59:47 +0200
committerAlexander F. Rødseth2020-08-11 23:59:47 +0200
commitb22c1b0faf893691d64ce0a05cd256101de0dbed (patch)
treea01f3fe9de31d57a584d3c16d65496a470c16505 /PKGBUILD
parentea0da09e1dee0cc35512b4efe6337fa8b3c4a66c (diff)
downloadaur-b22c1b0faf893691d64ce0a05cd256101de0dbed.tar.gz
New release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20425c12e2c9..5f159c0278af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=o
-pkgver=2.32.2
+pkgver=2.32.4
pkgrel=1
pkgdesc='Small, fast and VT100-compatible text editor'
arch=(x86_64)
url='https://github.com/xyproto/o'
license=(BSD)
fmakedepends=(git go)
-source=("git+$url#commit=cc165ce013be015b81f643610836e632985b1e81") # tag: 2.32.2
+source=("git+$url#commit=8d2860a7b4baea09b10251bbf450b6e9f9e29a96") # tag: 2.32.4
sha256sums=('SKIP')
options=(!strip)
optdepends=('cxx: for compiling C++'
@@ -27,7 +27,10 @@ optdepends=('cxx: for compiling C++'
'kotlin: for compiling Kotlin'
'crystal: for compiling Crystal'
'java-environment: for compiling Java'
- 'google-java-format: for formatting Java')
+ 'google-java-format: for formatting Java'
+ 'fpc: for compiling Object Pascal'
+ 'lua-format: for formatting Lua'
+ 'lua: for compiling Lua')
build() {
cd $pkgname
@@ -39,6 +42,7 @@ build() {
package() {
install -Dm755 $pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 $pkgname/$pkgname "$pkgdir/usr/bin/red"
install -Dm644 $pkgname/$pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}