summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCoşku Baş2016-09-17 19:46:54 +0300
committerCoşku Baş2016-09-17 19:46:54 +0300
commit8664b4887318f220190efee758672d2fb65566d0 (patch)
tree30fe3efc0af91d1e72b5860698c056deac5ac90c /PKGBUILD
downloadaur-8664b4887318f220190efee758672d2fb65566d0.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4df780e361f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Cosku Bas <cosku.bas@gmail.com>
+
+pkgname=objectivelymvc-git
+pkgver=r252.dd425fd
+pkgrel=1
+pkgdesc="Object oriented MVC framework for OpenGL, SDL2 and GNU C. Inspired by Apple's AppKit."
+arch=('i686' 'x86_64')
+url="https://github.com/jdolan/Objectively"
+license=('zlib')
+
+makedepends=('git' 'clang' 'autoconf' 'automake' 'check')
+depends=('objectively-git' 'sdl2' 'sdl2_image' 'sdl2_ttf' 'fontconfig')
+
+source=(git://github.com/jdolan/ObjectivelyMVC)
+sha1sums=('SKIP')
+
+build() {
+ cd ObjectivelyMVC
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+pkgver() {
+ cd ObjectivelyMVC
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ObjectivelyMVC
+ make DESTDIR="${pkgdir}" install
+}