summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Anderson2016-11-28 22:00:10 -0800
committerEric Anderson2016-11-28 22:00:10 -0800
commit4b13d3e3cd2b2ed519e3f2cd3a9d76c672517801 (patch)
tree8db0dde0adba11021a627f8632d40ce0287d5760 /PKGBUILD
parentcd2c6d3a48e219c3e94a126019143b80c9a7dfcb (diff)
downloadaur-4b13d3e3cd2b2ed519e3f2cd3a9d76c672517801.tar.gz
Update to 1.20.2
This is a mostly useless update. The only change to upstream in 1.20.1 and 1.20.2 is a new explicit dependency on gnupg in Debian since it was no longer implicitly included via build-essential. That seems a bit strange since that should imply gnupg is only a build dependency, but it is used at runtime as well. It's also unclear why the dependency is a 'Depends' instead of a 'Suggests', since it is only necessary when using encryption. Maybe I don't understand the semantics of Suggests. This has little impact for Arch because pacman transitively depends on gnupg. Obnam could have an optional dependency on gnupg, but gnupg is already installed on virtually all Arch machines and upstream chose a strong dependency.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 230ba3f7baaf..d419835dab49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=obnam
-pkgver=1.20
+pkgver=1.20.2
pkgrel=1
pkgdesc="Easy, secure backup program"
arch=('i686' 'x86_64')
url="http://obnam.org/"
license=('GPL3')
depends=('python2-paramiko' 'python2-tracing' 'python2-larch'
- 'python2-ttystatus' 'python2-cliapp')
+ 'python2-ttystatus' 'python2-cliapp' 'gnupg')
optdepends=('python2-fuse: support for mounting backups')
source=("http://code.liw.fi/debian/pool/main/o/obnam/obnam_$pkgver.orig.tar.xz")
-sha256sums=('08b674f400f7c132a560af5b23bc080bd96f95c4738d41713cff90d41f3a30f1')
+sha256sums=('b84a39d976acb007414c1ed972c0869693f38c185889bb8bb4f1a61ce5b30f65')
build() {
cd "$srcdir/$pkgname-$pkgver"