summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522021-02-02 10:05:13 +0100
committertytan6522021-02-02 10:05:13 +0100
commitedb743e979f52540bc849a2149a30eadd6bb2e06 (patch)
treedf558bbd0876c4d2d3b75bdc6063d7221cceac62 /PKGBUILD
downloadaur-edb743e979f52540bc849a2149a30eadd6bb2e06.tar.gz
build: add version 0.2.0 with pulse
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d72266b6472
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: tytan652 <tytan652@tytanium.xyz>
+pkgname=obs-audio-monitor
+pkgver=0.2.0
+_obsver=26.1.2
+pkgrel=1
+pkgdesc="Plugin for OBS Studio to add Audio Monitor dock and filter"
+arch=('x86_64')
+url="https://github.com/exeldro/obs-audio-monitor"
+license=("GPL2")
+depends=("obs-studio")
+# Need to compile plugin in OBS compilation process
+makedepends=(
+ 'cmake' 'libfdk-aac' 'libxcomposite' 'x264' 'vlc' 'swig' 'python'
+ 'luajit' 'ffmpeg' 'jansson' 'libxinerama' 'libxkbcommon-x11' 'mbedtls'
+ 'qt5-svg' 'qt5-x11extras' 'curl' 'jack' 'gtk-update-icon-cache'
+)
+source=(
+ "$pkgname-$pkgver::git+https://github.com/exeldro/obs-audio-monitor#commit=31b7586f9bd58013f2674e3305cf7a462114dd1f"
+ "obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
+ "fix_python_binary_loading.patch"
+)
+sha256sums=(
+ 'SKIP'
+ 'bc8b4c61ba4aae87b70c589a6a5b8538e4f03121b31e9b98a2071d9f6006b897'
+ 'bdfbd062f080bc925588aec1989bb1df34bf779cc2fc08ac27236679cf612abd'
+)
+
+prepare() {
+ rm -rf fakeroot
+ cd "obs-studio-$_obsver"
+ patch -Np1 < "$srcdir"/fix_python_binary_loading.patch
+ cd UI/frontend-plugins
+ cp -r "$srcdir/$pkgname-$pkgver" .
+ echo "add_subdirectory($pkgname-$pkgver)" | tee -a CMakeLists.txt >/dev/null
+ # add pulse
+ cd "$pkgname-$pkgver"
+ git cherry-pick --no-commit 691a0447227ac82737d321889ee741ee411af7c5
+}
+
+# Need to compile plugin in OBS compilation process
+build() {
+ cd "obs-studio-$_obsver"
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DBUILD_CAPTIONS=ON
+ make -C build
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/lib/obs-plugins
+ mkdir -p "$pkgdir"/usr/share/obs/obs-plugins
+
+ cd "obs-studio-$_obsver"
+ make -C build DESTDIR="$srcdir/fakeroot/" install
+ cp -a "$srcdir"/fakeroot/usr/lib/obs-plugins/audio-monitor.so "$pkgdir"/usr/lib/obs-plugins/
+ cp -a "$srcdir"/fakeroot/usr/share/obs/obs-plugins/audio-monitor "$pkgdir"/usr/share/obs/obs-plugins/
+} \ No newline at end of file