summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522021-10-26 11:50:43 +0200
committertytan6522021-10-26 11:50:43 +0200
commit1a4ebe3849c0fcddd7a22f19cd0d31f2bfeb5a95 (patch)
treef72f99c62f6f120d24849668921815b293c365e9 /PKGBUILD
downloadaur-1a4ebe3849c0fcddd7a22f19cd0d31f2bfeb5a95.tar.gz
build: Initial version 0.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc75b641de7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: tytan652 <tytan652@tytanium.xyz>
+
+_pluginname=downstream-keyer
+pkgname=obs-$_pluginname
+pkgver=0.2.1
+_obsver=27.0.0
+pkgrel=1
+pkgdesc="Add a Downstream Keyer dock to OBS studio"
+arch=("i686" "x86_64" "aarch64")
+url="https://obsproject.com/forum/resources/downstream-keyer.1254/"
+license=("GPL2")
+depends=("obs-studio>=$_obsver")
+makedepends=("cmake" "git" "libxcomposite")
+source=(
+ "$pkgname::git+https://github.com/exeldro/$pkgname#commit=f73deed2076ff4359d9d8beb4040393520fd63a7"
+ "obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
+)
+sha256sums=(
+ "SKIP"
+ "c7ea5369f4c94203a8a81b73c6372873f08ab9e5b20860691dad2c29f5dda85e"
+)
+
+prepare() {
+ rm -rf fakeroot
+
+ cd "obs-studio-$_obsver"/UI/frontend-plugins
+ cp -r "$srcdir/$pkgname" .
+ echo "add_subdirectory($pkgname)" | tee -a CMakeLists.txt >/dev/null
+}
+
+# Need to compile plugin in OBS compilation process
+build() {
+ cd "obs-studio-$_obsver"
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_UI=ON \
+ -DENABLE_WAYLAND=OFF \
+ -DENABLE_PIPEWIRE=OFF \
+ -DENABLE_SCRIPTING=OFF \
+ -DDISABLE_DECKLINK=ON \
+ -DDISABLE_ALSA=ON \
+ -DDISABLE_JACK=ON \
+ -DDISABLE_PULSEAUDIO=ON \
+ -DDISABLE_V4L2=ON \
+ -DDISABLE_SPEEXDSP=ON \
+ -DDISABLE_LIBFDK=ON \
+ -DDISABLE_SNDIO=ON \
+ -DDISABLE_FREETYPE=ON \
+ -DDISABLE_VLC=ON \
+ -DBUILD_BROWSER=OFF \
+ -DBUILD_VST=OFF \
+ -DWITH_RTMPS=OFF
+
+ make -C build
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/lib/obs-plugins
+ mkdir -p "$pkgdir"/usr/share/obs/obs-plugins
+
+ cd "obs-studio-$_obsver"
+ make -C build DESTDIR="$srcdir/fakeroot/" install
+ cp -a "$srcdir"/fakeroot/usr/lib/obs-plugins/$_pluginname.so "$pkgdir"/usr/lib/obs-plugins/
+ cp -a "$srcdir"/fakeroot/usr/share/obs/obs-plugins/$_pluginname "$pkgdir"/usr/share/obs/obs-plugins/
+} \ No newline at end of file