summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgloomy-ghost2018-05-05 10:18:00 +0000
committergloomy-ghost2018-05-05 22:18:01 +1200
commit0f3d64391884143bab0492337f0ba3675c4d43f0 (patch)
treee0c6f3c0bb6c2bed3b542a828bf82bfe6ab85a35 /PKGBUILD
downloadaur-0f3d64391884143bab0492337f0ba3675c4d43f0.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f6e867e8c75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: ghost <i at ghosts dot work>
+pkgname=obs-gnome-screencast
+pkgver=0.0.8
+pkgrel=1
+pkgdesc="GNOME Screen Cast OBS Studio plugin, supports Wayland"
+arch=('any')
+url="https://github.com/fzwoch/$pkgname"
+license=('GPL-2')
+depends=('gnome-shell'
+ 'obs-studio')
+makedepends=('meson')
+optdepends=()
+source=("https://github.com/fzwoch/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('3CD676E6A2A3DE065C7F903A16E64694BCC5408217CA707AEB7E0A72E5AC42C9')
+
+build() {
+ cd "$pkgname-$pkgver"
+ meson --buildtype=release build
+ ninja -C build
+}
+
+package() {
+ sudo cp "$pkgname-$pkgver/build/gnome-screencast.so" /usr/lib/obs-plugins/
+} \ No newline at end of file