summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Garfias2020-12-14 23:06:41 -0600
committerDavid Garfias2020-12-14 23:06:41 -0600
commit3747b0f1515f4991e6cd54423d7a97eedc04b453 (patch)
tree1e962dbeb94b0e48ae5e35ca2613ae22ffc2c8c7 /PKGBUILD
parentab7e6037de3b1a526685831c9e0b2efea01cc867 (diff)
downloadaur-3747b0f1515f4991e6cd54423d7a97eedc04b453.tar.gz
Removed CHANGELOG file, updated meson commands as shown in the wiki
and removed dependency on gtk3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbb13a2958d9..9d7519e70737 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: Nahuel Gomez Castro <nahual_gomca@outlook.com.ar>
-# Contributor: schard <mail at richard dash neumann period de>
+# Maintainer: David Garfias <jose.garfias@ingenieria.unam.edu>
+# Contributor: Nahuel Gomez Castro <nahual_gomca@outlook.com.ar>
+# Contributor: schard <mail@richard.neumann.de>
pkgname='obs-gnome-screencast'
pkgver='0.1.1'
-pkgrel='1'
+pkgrel='2'
pkgdesc="GNOME Screen Cast OBS Studio plugin"
changelog='CHANGELOG'
arch=('x86_64')
url="https://github.com/fzwoch/${pkgname}"
license=('GPL2')
-depends=('gnome-shell' 'obs-studio' 'gtk3' 'gstreamer' 'gst-plugins-base-libs')
+depends=('gnome-shell' 'obs-studio' 'gstreamer' 'gst-plugins-base-libs')
makedepends=('meson' 'git')
source=("${url}/archive/v${pkgver}.tar.gz")
sha256sums=('a67e06a3473a4418ce5437e74aa82a55fe70a7f7d6d61d3e68047973b458db41')
build() {
- arch-meson "${pkgname}-${pkgver}" build
- ninja -C build
+ arch-meson "${pkgname}-${pkgver}" build
+ meson compile -C build
}
package() {
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="${pkgdir}" ninja install -C build
}