summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNahuel Gomez Castro2020-02-21 16:25:36 -0300
committerNahuel Gomez Castro2020-02-21 16:25:36 -0300
commit3db3ff6800aeeb6388479579c56ed5651466e4f1 (patch)
treed73502d5d3dcfa619ec1c2bdf4e36bbd0ced273b /PKGBUILD
parentc59a19b941a9e73033c5ab8d5fd78cf27e4cb69b (diff)
downloadaur-3db3ff6800aeeb6388479579c56ed5651466e4f1.tar.gz
Refactored PKGBUILD in order to use git tags instead of tarball, and added CHANGELOG
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ef8227d6c94..7760885dca71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: schard <mail at richard dash neumann period de>
-pkgname=obs-gnome-screencast
-pkgver=0.1.0
-pkgrel=1
-pkgdesc="GNOME Screen Cast OBS Studio plugin, supports Wayland"
-arch=('any')
+# Maintainer: Nahuel Gomez Castro <nahual_gomca@outlook.com.ar>
+# Contributor: schard <mail at richard dash neumann period de>
+
+pkgname='obs-gnome-screencast'
+pkgver='0.1.0'
+pkgrel='1'
+pkgdesc="GNOME Screen Cast OBS Studio plugin"
+changelog='CHANGELOG'
+arch=('x86_64')
url="https://github.com/fzwoch/${pkgname}"
license=('GPL2')
-depends=('gnome-shell' 'obs-studio')
-makedepends=('meson')
-source=("https://github.com/fzwoch/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('26f1c082c8b30f1d6046d7ad2f44a7b6a5664220c1eb3c41f7725d1510162ced')
-
+depends=('gnome-shell' 'obs-studio' 'gtk3' 'gstreamer' 'gst-plugins-base-libs')
+makedepends=('meson' 'git')
+source=("git+${url}.git#tag=v${pkgver}")
+sha256sums=('SKIP')
build() {
- meson --buildtype=release --prefix=/usr "${pkgname}-${pkgver}" "${pkgname}-${pkgver}/build"
- ninja -C "${pkgname}-${pkgver}/build"
+ arch-meson ${pkgname} build
+ ninja -C build
}
-
package() {
- DESTDIR="${pkgdir}" ninja -C "${pkgname}-${pkgver}/build" install
+ DESTDIR="${pkgdir}" ninja -C build install
}