summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard Neumann2019-09-24 16:53:56 +0200
committerRichard Neumann2019-09-24 16:53:56 +0200
commitf5a624fdedb2d8e5d6031d4da37b51e02f927bd4 (patch)
treeea3a25f7204ff0e765386451eb9d3168f867faf2 /PKGBUILD
parent5bdf930e007497fa165d200009a145c11990db88 (diff)
downloadaur-f5a624fdedb2d8e5d6031d4da37b51e02f927bd4.tar.gz
Updated PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 492d46a5c39e..93bd3fab6b07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: ghost <i at ghosts dot work>
+# Maintainer: schard <mail at richard dash neumann period de>
pkgname=obs-gnome-screencast
-pkgver=0.0.9
+pkgver=0.0.10
pkgrel=1
pkgdesc="GNOME Screen Cast OBS Studio plugin, supports Wayland"
arch=('any')
-url="https://github.com/fzwoch/$pkgname"
+url="https://github.com/fzwoch/${pkgname}"
license=('GPL-2')
depends=('gnome-shell'
'obs-studio')
makedepends=('meson')
optdepends=()
-source=("https://github.com/fzwoch/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('E2599E30AD55E1FCB2ABED85DF29630045397FD532DEE8AA61F97CE05AFB5186')
+source=("https://github.com/fzwoch/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('f452670c0ffee3b08296370e7cfe6ac2b442588942b96c78e0b1bf05f09b6e49')
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
meson --buildtype=release build
ninja -C build
}
package() {
- sudo cp "$pkgname-$pkgver/build/gnome-screencast.so" /usr/lib/obs-plugins/
-} \ No newline at end of file
+ install -Dm 644 "${pkgname}-${pkgver}/build/gnome-screencast.so" "${pkgdir}/usr/lib/obs-plugins/gnome-screencast.so"
+}