summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNexAdn2017-12-12 21:20:02 +0100
committerNexAdn2017-12-12 21:20:02 +0100
commitf501c76e1c12e39dedf61881bb1cfb5b06cac7af (patch)
treefd7dae16a3dcdd80fac7a2fc7f5b618ecac38f61 /PKGBUILD
downloadaur-f501c76e1c12e39dedf61881bb1cfb5b06cac7af.tar.gz
Initial commit
Signed-off-by: NexAdn <nexadn@yandex.com>
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a448d4569706
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: NexAdn
+pkgname=obs-linuxbrowser-bin
+pkgver=0.3.1
+_obsver=20.0.1
+pkgrel=1
+pkgdesc="Browser source plugin for obs-studio based on CEF. Alternative to obs-qtwebkit."
+arch=("x86_64")
+url="https://github.com/bazukas/obs-linuxbrowser"
+license=("GPL")
+provides=("obs-linuxbrowser")
+conflicts=("obs-linuxbrowser")
+depends=(
+ "obs-studio>=${_obsver}"
+ "gconf" "nss" "libxss" "pango" "atk" "libxrandr" "libxcomposite"
+)
+optdepends=("pepper-flash: Flash support")
+source=(
+ "https://github.com/bazukas/obs-linuxbrowser/releases/download/${pkgver}/linuxbrowser${pkgver}-obs${_obsver}-64bit.tgz"
+)
+sha256sums=('ae4e33d11dd3dc1aed440c7bcf1fb1da282cda39bc37fe771c900a7a4b468d28')
+package() {
+ cd ${srcdir}/obs-linuxbrowser
+ install -d ${pkgdir}/usr/lib/obs-plugins/
+ install -d ${pkgdir}/usr/share/obs/obs-plugins/obs-linuxbrowser/
+ install -Dm755 ./bin/64bit/* ${pkgdir}/usr/lib/obs-plugins/
+ cp -R ./data/* ${pkgdir}/usr/share/obs/obs-plugins/obs-linuxbrowser/
+}