summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2019-07-21 13:56:20 +0200
committerFrederik “Freso” S. Olesen2019-07-21 13:56:20 +0200
commit7b7dfcd334a485e635088dbadd0d1a54fae6800c (patch)
tree84c7391a3b50c48c514323c7aa7e444a572f8e90 /PKGBUILD
parent198b05b3f49ef1633a2d29f80506844016ee83ac (diff)
downloadaur-7b7dfcd334a485e635088dbadd0d1a54fae6800c.tar.gz
obs-linuxbrowser-git 0.6.1.r3.gb618678-1
The CEF<75 versioned dependency will be lifted once https://github.com/bazukas/obs-linuxbrowser/issues/108 is fixed.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79c0abae2841..0a2bd5bfab43 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
# Maintainer: NexAdn <nexadn@yandex.com>
-pkgname=obs-linuxbrowser
-pkgver=0.6.1
+_pkgname=obs-linuxbrowser
+pkgname=${_pkgname}-git
+pkgver=0.6.1.r3.gb618678
pkgrel=1
pkgdesc="Browser source plugin for obs-studio based on CEF. Alternative to obs-qtwebkit."
arch=("i686" "x86_64")
url="https://github.com/bazukas/obs-linuxbrowser"
license=("GPL")
-conflicts=("obs-linuxbrowser-bin")
+conflicts=("${_pkgname}" "obs-linuxbrowser-bin")
depends=(
"obs-studio>=21.1.2"
"gconf" "nss" "libxss" "pango" "atk" "libxrandr" "libxcomposite"
)
-makedepends=("make" "cmake" "git" "cef-minimal")
+makedepends=("make" "cmake" "git" "cef-minimal<75")
optdepends=("pepper-flash: Flash support"
"cef-minimal: Up-to-date browser backend")
source=(
- "${pkgname}::git+https://github.com/bazukas/${pkgname}.git"
+ "${_pkgname}::git+https://github.com/bazukas/${_pkgname}.git"
)
sha256sums=('SKIP')
-prepare() {
- cd "$srcdir"/"${pkgname}"
- git checkout ${pkgver}
+
+pkgver() {
+ cd "${srcdir}"/${_pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+
build() {
- cd "${srcdir}"/${pkgname}
+ cd "${srcdir}"/${_pkgname}
mkdir -p ./build
cd ./build
cmake -DCEF_ROOT_DIR="/opt/cef" -DINSTALL_SYSTEMWIDE=true -DCMAKE_INSTALL_PREFIX="/usr" ..
@@ -31,6 +34,6 @@ build() {
}
package() {
- cd "${srcdir}"/${pkgname}/build
+ cd "${srcdir}"/${_pkgname}/build
make DESTDIR="${pkgdir}" install
}