summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBjörn Bidar2022-07-20 17:03:17 +0300
committerBjörn Bidar2022-07-20 17:03:17 +0300
commitfb49a572ea45d1757fa9eabd8b15fe019d61f76d (patch)
tree08f36fe42077f73479dff744ea011cee7a4f8631 /PKGBUILD
downloadaur-fb49a572ea45d1757fa9eabd8b15fe019d61f76d.tar.gz
Added as of 0.13.2-1
- Initial packaging Signed-off-by: Björn Bidar <bjorn.bidar@thaodan.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d619e067b306
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Thaodan <AUR+me@thaodan.de>
+
+pkgname=obs-service-repo
+pkgver=0.13.2
+pkgrel=1
+pkgdesc="Repo service designed for droid-hal-device builds"
+arch=('any')
+url="https://github.com/MeeGoIntegration/obs-service-repo"
+license=('GPL2')
+groups=('obs')
+depends=(
+ git
+ repo
+ pbzip2
+)
+
+optdepends=()
+source=("$pkgname-$pkgver.tar.gz::https://github.com/MeeGoIntegration/obs-service-repo/archive/$pkgver.tar.gz")
+sha512sums=('d430665404e7f000864c1d224ce30208ce0f60f7b6705dfb159b093a17242d882037473b704ccbb2bedade89f9137ada4c705ecbbe00b1e3dd0e1b57860975a4')
+
+
+package() {
+ cd "$pkgname-$pkgver"
+ # mkdir -p ${pkgdir}/etc/cron.d/
+
+ install -Dm755 repo ${pkgdir}/usr/lib/obs/service/repo
+ install -m644 repo.service ${pkgdir}/usr/lib/obs/service/repo.service
+
+ #cp repo-service-cronjob ${pkgdir}/usr/lib/obs/service/
+ #cp repo.crontab ${pkgdir}/etc/cron.d/
+}