summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522024-04-23 16:14:57 +0200
committertytan6522024-04-23 16:14:57 +0200
commitdd478d15b3c01e91501ff14a71add122e24b2606 (patch)
treefaf356b7ab6e91062ca2236553f3b6ac879e774c /PKGBUILD
parenta15201dbb6ed210358181a184cea8278fdb3f4c6 (diff)
downloadaur-dd478d15b3c01e91501ff14a71add122e24b2606.tar.gz
build: Update to version 0.3.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 432befca788e..900d9c039a0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=obs-source-record
-pkgver=0.3.2
-pkgrel=2
+pkgver=0.3.4
+pkgrel=1
pkgdesc="Plugin for OBS Studio to add a filter that allows you to record a source"
arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/source-record.1285/"
-license=("GPL2")
+license=("GPL-2.0-or-later")
depends=("obs-studio>=29")
makedepends=("cmake" "git")
options=("debug")
-source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=4e27c040031831f9e9959f4947a6904ebe0fa23a")
+source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=3c42da3785704d68ef800ac1d8f4b3fb890548e2")
sha256sums=("SKIP")
build() {
@@ -20,7 +20,8 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \
-DQT_VERSION=6 \
- -DCMAKE_C_FLAGS="-Wno-error=deprecated-declarations"
+ -DCMAKE_C_FLAGS="-Wno-error=deprecated-declarations" \
+ -Wno-dev
cmake --build build
}