summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlice Gaudon2020-11-05 10:29:04 +0100
committerAlice Gaudon2020-11-05 10:29:43 +0100
commit208125d805760f40dbc61b53edfc30ee20cbe07e (patch)
treea4bab791bf9cc085e3a13cf4b38372432d0e110a /PKGBUILD
parentbda9903adafe06ee4f7096ce7180b2ddf068a426 (diff)
downloadaur-208125d805760f40dbc61b53edfc30ee20cbe07e.tar.gz
Rename package and pin to latest stable release tag 26.0.2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4592bf301f0e..d3a16ab97875 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Benjamin Klettbach <b dot klettbach at gmail dot com >
+# Maintainer: Alice Gaudon <alice at gaudon dot pro>
+# Contributor: Benjamin Klettbach <b dot klettbach at gmail dot com >
# Contributor: Jonathan Steel <jsteel at archlinux.org>
# Contributor: ArcticVanguard <LideEmily at gmail dot com>
# Contributor: ledti <antergist at gmail dot com>
-pkgname=obs-studio-git
-pkgver=25.0.7.r302.gc21fd6f27
+pkgname=obs-studio-browser
+pkgver=26.0.2
pkgrel=1
-pkgdesc="Free and open source software for video recording and live streaming."
+pkgdesc="Free and open source software for video recording and live streaming. Built with the browser plugin."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
license=("GPL2")
@@ -22,16 +23,11 @@ optdepends=("libfdk-aac: FDK AAC codec support"
"python: Python scripting")
provides=("obs-studio=$pkgver")
conflicts=("obs-studio")
-source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#branch=master"
+source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"git+https://github.com/Mixer/ftl-sdk.git"
"git+https://github.com/obsproject/obs-browser.git")
md5sums=("SKIP" "SKIP" "SKIP")
-pkgver() {
- cd $pkgname
- git describe --long --tags | sed -r "s/([^-]*-g)/r\1/;s/-/./g"
-}
-
prepare() {
cd $pkgname
git config submodule.plugins/obs-outputs/ftl-sdk.url $srcdir/ftl-sdk