summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522023-07-22 08:27:23 +0200
committertytan6522023-07-22 08:27:23 +0200
commit7dbb355d4cace5305b87b4dccf55c20c755dd131 (patch)
treecf372be8af58b09b4256f08a5e98068dadc886aa /PKGBUILD
parent0eb70fa493bb42ec2596049a948d99bfcad79b70 (diff)
downloadaur-7dbb355d4cace5305b87b4dccf55c20c755dd131.tar.gz
build: Add -Wno-error=dangling-reference
Yes, further needs to be done to know if the this a false positive or not
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e13f82d80c2..528d696118e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=obs-studio-browser
pkgver=29.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integration"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -130,6 +130,8 @@ prepare() {
}
build() {
+ export CXXFLAGS="$CXXFLAGS -Wno-error=dangling-reference"
+
cmake -B build -S obs-studio \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \