summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbenklett2017-08-30 19:49:33 +0200
committerbenklett2017-08-30 19:49:33 +0200
commitbe06772575d4f5fe98291091f07a1fc6e24c3027 (patch)
tree27fa671ae71dc21f468215ebed8354bffb3e5aad /PKGBUILD
parent12350c012539f3b12db66d10a7e37a46b80fef7b (diff)
downloadaur-be06772575d4f5fe98291091f07a1fc6e24c3027.tar.gz
Add ftl-sdk submodule for FTL support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e0c10d723a8..a0b23a5f7244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: ledti <antergist at gmail dot com>
pkgname=obs-studio-git
-pkgver=0.16.1.r0.g6d16c51
+pkgver=20.0.1.r11.g41a1b099
pkgrel=1
pkgdesc="Free and open source software for video recording and live streaming."
arch=("i686" "x86_64")
@@ -19,14 +19,22 @@ optdepends=("libfdk-aac: FDK AAC codec support"
"vlc: VLC Media Source")
provides=("obs-studio")
conflicts=("obs-studio")
-source=("$pkgname::git+https://github.com/jp9000/obs-studio.git#branch=master")
-md5sums=("SKIP")
+source=("$pkgname::git+https://github.com/jp9000/obs-studio.git#branch=master"
+ "git+https://github.com/Mixer/ftl-sdk.git")
+md5sums=("SKIP" "SKIP")
pkgver() {
cd $pkgname
git describe --long --tags | sed -r "s/([^-]*-g)/r\1/;s/-/./g"
}
+prepare() {
+ cd $pkgname
+ git submodule init
+ git config submodule.plugins/obs-outputs/ftl-sdk.url $srcdir/ftl-sdk
+ git submodule update
+}
+
build() {
cd $pkgname