summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522023-09-01 12:29:22 +0200
committertytan6522023-09-01 12:29:22 +0200
commitc23cfa0521041f3373e70508cc8f48d4a2201491 (patch)
tree53d95077a26874de580fac9067fec03ee0e08efc /PKGBUILD
parent7dbb355d4cace5305b87b4dccf55c20c755dd131 (diff)
downloadaur-c23cfa0521041f3373e70508cc8f48d4a2201491.tar.gz
build: Backport changes
- Fix blank browser dock titles with Qt 6.5 - Use system-wide uthash RC package backport
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 528d696118e3..b79a277c5942 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=obs-studio-browser
pkgver=29.1.3
-pkgrel=2
+pkgrel=3
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integration"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -66,6 +66,7 @@ makedepends=(
"cmake"
"jack" # Deps of JACK plugin
"git"
+ "uthash" # Deps of libobs
"libajantv2" # Deps of AJA plugin (static lib)
"libfdk-aac" # Deps of FDK AAC plugin
"luajit" # Deps of Scripting plugin
@@ -106,12 +107,18 @@ source=(
"obs-browser::git+https://github.com/obsproject/obs-browser.git"
"obs-websocket::git+https://github.com/obsproject/obs-websocket.git"
"qr::git+https://github.com/nayuki/QR-Code-generator.git"
+ "0001-Add_finder_for_uthash.patch"
+ "0002-Use_system_uthash.patch"
+ "0003-Fix_blank_browser_dock_titles.patch"
)
sha256sums=(
"SKIP"
"SKIP"
"SKIP"
"SKIP"
+ "f4a56021a7f1c564f95b588d7c09b60a89efa2c1954c8a418cf6320b5a818542"
+ "966250c40ab47276e1d420941b5b1e448886b0ab8643f25ba37dce08df68f34d"
+ "8980d1e871177c3f65d5cf0c249ef36c5a9e2a6956bbc592283782ec58d825e7"
)
if [[ $CARCH == 'x86_64' ]]; then
@@ -124,6 +131,11 @@ prepare() {
git config submodule.plugins/obs-websocket.url $srcdir/obs-websocket
git -c protocol.file.allow=always submodule update
+ patch -Np1 -i "$srcdir/0001-Add_finder_for_uthash.patch"
+ patch -Np1 -i "$srcdir/0002-Use_system_uthash.patch"
+ # https://github.com/obsproject/obs-studio/pull/9373
+ patch -Np1 -i "$srcdir/0003-Fix_blank_browser_dock_titles.patch"
+
cd plugins/obs-websocket
git config submodule.deps/qr.url $srcdir/qr
git -c protocol.file.allow=always submodule update deps/qr