summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlice Gaudon2021-09-30 10:52:40 +0200
committerAlice Gaudon2021-09-30 10:53:32 +0200
commite36151613a9dc4afd52adca2c0ca586c2ca171ee (patch)
tree3193b3012d654f503a526c82d2ad54fb36897adf /PKGBUILD
parent2da21480436176e656f966136f8d44f7d2d83d38 (diff)
downloadaur-e36151613a9dc4afd52adca2c0ca586c2ca171ee.tar.gz
Update cef91.patch and add it back
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c3564b78633..6fbf5dd8f382 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=obs-studio-browser
pkgver=27.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Free and open source software for video recording and live streaming. Built with browser, vst plugins."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
@@ -32,12 +32,14 @@ source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"git+https://github.com/Mixer/ftl-sdk.git"
"git+https://github.com/obsproject/obs-browser.git"
"git+https://github.com/obsproject/obs-vst.git"
- "fix_python_binary_loading.patch")
+ "fix_python_binary_loading.patch"
+ "cef91.patch")
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '93ad704cef425073b417d1ed95e076f688a6e45cdf589472c65e437d77297303f31dd8f15c7d5e30f83276a6396b732dfb5a695db9c773911aaa0423c5262177')
+ '93ad704cef425073b417d1ed95e076f688a6e45cdf589472c65e437d77297303f31dd8f15c7d5e30f83276a6396b732dfb5a695db9c773911aaa0423c5262177'
+ '27b816c79545e6039445e1487a258c1233f5d43df3178fd274a9ede607138fc6dbb58a21ec78431bc5774d18153f9c6a08f61649b9b1a6a628ce358d5cf12093')
prepare() {
cd "$srcdir/$pkgname"
@@ -46,6 +48,7 @@ prepare() {
git config submodule.plugins/obs-browser.url "$srcdir"/obs-browser
git config submodule.plugins/obs-vst.url "$srcdir"/obs-vst
git submodule update
+ patch -d "$srcdir/$pkgname/plugins/obs-browser" -Np1 < "$srcdir"/cef91.patch
}
build() {