summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522021-09-29 11:10:14 +0200
committertytan6522021-09-29 11:10:14 +0200
commit5fb793ddcadd31cf859fcd9a5668d454ea074713 (patch)
tree84c1aebf21b0974829efed328a4ab081967e913a /PKGBUILD
parent3cc1a80a995d5daa6b350054c9b4d69394931191 (diff)
downloadaur-5fb793ddcadd31cf859fcd9a5668d454ea074713.tar.gz
build: Add a nice patch for VAAPI encoder
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8af6968c9cdf..2371852046dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=obs-studio-tytan652
pkgver=27.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Free and open source software for video recording and live streaming. With Browser dock and sources, VST 2 filter, FTL protocol, VLC sources, V4L2 devices by paths, my bind interface PR, and sometimes backported fixes."
arch=("i686" "x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
license=("GPL2")
depends=("ffmpeg" "mbedtls" "jack" "gtk-update-icon-cache" "x264" "rnnoise"
+ "pciutils"
# "libxinerama" "qt5-svg" provided by "vlc-luajit"
# "libxkbcommon-x11" provided by "qt5-base"
@@ -54,6 +55,8 @@ source=(
"python_fix.patch" # https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/3335.patch
"bind_iface.patch" # Based on https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/4219.patch
"v4l2_by-path.patch" # https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/3437.patch
+ "FindLibpci.cmake" # https://github.com/carlocastoldi/obs-studio/blob/2936-fix/cmake/Modules/FindLibpci.cmake
+ "vaapi_set_dri_devices.patch" # Based on https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/5336.patch
"obs-browser::git+https://github.com/obsproject/obs-browser.git"
"obs-vst::git+https://github.com/obsproject/obs-vst.git#commit=cca219fa3613dbc65de676ab7ba29e76865fa6f8"
)
@@ -62,6 +65,8 @@ sha256sums=(
"430d7d0a7e1006c1f6309ad7d4912033dadd542b641f9d41259a5bad568379c9"
"a43f2ad974104888ef36eef49b3e60dc26f7cfc0f48300726c861978ae5ae3ea"
"fb55dffcb177fd89c2cbffeb14aaf920dae2ae60dcfa934cff252315f268470e"
+ "916f9fb3819c9d952140d65434e9dffc77b688dc1dc027b39226c33ee97be63f"
+ "5c18a85f95090f01a9eb24aeea13220f8698f8d433970e4dc6391432d033f065"
"SKIP"
"SKIP"
)
@@ -83,6 +88,11 @@ prepare() {
## linux-v4l2: Save device by path (https://github.com/obsproject/obs-studio/pull/3437)
patch -Np1 < "$srcdir/v4l2_by-path.patch"
+
+ ## obs-ffmpeg: Set DRI devices and their name persistently (https://github.com/obsproject/obs-studio/pull/5336)
+ patch -Np1 < "$srcdir/vaapi_set_dri_devices.patch"
+ # Add CMake finder for libpci (pciutils)
+ cp "$srcdir/FindLibpci.cmake" cmake/Modules/
}
build() {