summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522021-09-29 17:37:04 +0200
committertytan6522021-09-29 17:37:04 +0200
commit8b8378a580829a1864db011bede30ff76d9e3bae (patch)
tree47f735e0836e4e44710ba9799a54e150f80a2ca7 /PKGBUILD
parent5fb793ddcadd31cf859fcd9a5668d454ea074713 (diff)
downloadaur-8b8378a580829a1864db011bede30ff76d9e3bae.tar.gz
build: Fix plugin building with C99
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2371852046dd..63763af05eaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=obs-studio-tytan652
pkgver=27.1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Free and open source software for video recording and live streaming. With Browser dock and sources, VST 2 filter, FTL protocol, VLC sources, V4L2 devices by paths, my bind interface PR, and sometimes backported fixes."
arch=("i686" "x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -93,6 +93,9 @@ prepare() {
patch -Np1 < "$srcdir/vaapi_set_dri_devices.patch"
# Add CMake finder for libpci (pciutils)
cp "$srcdir/FindLibpci.cmake" cmake/Modules/
+
+ ## Fixup for plugins that compile with C99 by default
+ sed -i 's/PTHREAD_MUTEX_RECURSIVE/PTHREAD_MUTEX_RECURSIVE_NP/g' libobs/util/threading.h
}
build() {