summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522022-09-07 12:02:11 +0200
committertytan6522022-09-07 12:02:11 +0200
commit91b545dc52014ab2cc23659669ab62201a71b43e (patch)
tree0011ea3373471f931517f18714bcf24e7f5b5851 /PKGBUILD
parent155513c8eea65e0e48ef997a1ccb631a6b1a4d49 (diff)
downloadaur-91b545dc52014ab2cc23659669ab62201a71b43e.tar.gz
build: Re-use cef-minimal-obs package
I finally found the issue, revert the previous commit since doing that also fix the previous issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 4 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cee4770e57a..6252104bbb17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DISTRIB_ID=`lsb_release --id | cut -f2 -d$'\t'`
pkgname=obs-studio-tytan652
pkgver=28.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -85,7 +85,7 @@ else
fi
provides=("obs-studio=$pkgver" "obs-vst" "obs-websocket")
conflicts=("obs-studio" "obs-vst" "obs-websocket")
-options=('!strip')
+options=('debug')
source=(
"obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"obs-browser::git+https://github.com/obsproject/obs-browser.git"
@@ -119,14 +119,10 @@ if [[ $CARCH == 'x86_64' ]]; then
fi
if [[ $CARCH == 'x86_64' ]]; then
- _cefbranch=5060
- source+=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux64.tar.bz2")
- sha256sums+=("ac4e2a8ebf20700e4e36353e314f876623633dd5b474778a2548bb66bdbea11d")
+ makedepends+=("cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1")
provides+=("obs-browser")
conflicts+=("obs-linuxbrowser" "obs-browser")
_browser=ON
- _arch=64
- _parch=x86_64
else
_browser=OFF
fi
@@ -155,17 +151,6 @@ prepare() {
}
build() {
- if [[ $CARCH == 'x86_64' ]]; then
- cd "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}
-
- #The arm64 CEF set the wrong arch for the project
- cmake \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DPROJECT_ARCH=$_parch .
-
- make libcef_dll_wrapper
- fi
-
cd "$srcdir"/obs-studio
mkdir -p build; cd build
@@ -179,7 +164,7 @@ build() {
-DENABLE_JACK=ON \
-DENABLE_SNDIO=ON \
-DENABLE_BROWSER=$_browser \
- -DCEF_ROOT_DIR="$srcdir/cef_binary_${_cefbranch}_linux${_arch}" \
+ -DCEF_ROOT_DIR=/opt/cef-obs \
-DOBS_VERSION_OVERRIDE="$pkgver-tytan652-$pkgrel" ..
make