summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522024-11-12 10:58:12 +0100
committertytan6522024-11-12 10:58:12 +0100
commitd8dcf123e4f005dbcec8e998f236261b6e9e12e1 (patch)
tree3375bf0c00dcf67d999da9043cd302c6ddbcbb2f /PKGBUILD
parentc3e4c1d05c65b6303fed38da72d2d9d6ea390d93 (diff)
downloadaur-d8dcf123e4f005dbcec8e998f236261b6e9e12e1.tar.gz
build: Fix lossless audio encoder with FFmpeg 7.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 358c06d0f152..5766752f9896 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=obs-studio-tytan652
pkgver=30.2.3
-pkgrel=2
+pkgrel=3
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integrations. Plus my bind interface PR, and sometimes backported fixes"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -140,6 +140,9 @@ prepare() {
## Add network interface binding for RTMP on Linux (https://github.com/tytan652/obs-studio/commits/bind_iface_eyeballed)
patch -Np1 < "$srcdir/bind_iface_eyeballed.patch"
+ # obs-ffmpeg: Avoid setting negative bitrate for lossless audio codec
+ sed -i 's/enc->context->bit_rate = -1;/enc->context->bit_rate = 0;/g' plugins/obs-ffmpeg/obs-ffmpeg-audio-encoders.c
+
cd "$srcdir"
make PREFIX="$srcdir/nv-prefix" -C supported-nv-codec-headers install
}