summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2020-09-18 07:39:14 -0300
committerRafael Fontenelle2020-09-18 07:39:20 -0300
commit16dc88764234c7abf0087f92abb531270f12f27c (patch)
treeafe99423284a3d66214554654247e364bc47987b /PKGBUILD
parent7f2bcca7cec6d0352f340818e950264c0f8e759f (diff)
downloadaur-16dc88764234c7abf0087f92abb531270f12f27c.tar.gz
Update depends and remove patch
Now depends on AUR package obs-studio-wayland, as the obs-studio from official repositories currently doesn't provide the header libobs/obs-nix-platform.h Remove patch file which doesn't apply anymore after changes in the source file. As a consequence, remove empty prepare(). Finally drop _pkgname variable, use bash magic instead.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 11 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a039bef3be1..6b7bfdf2be83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,26 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
# Contributor: Davide Depau <davide@depau.eu>
-_pkgname="obs-xdg-portal"
-pkgname="${_pkgname}-git"
-pkgver=0.1.2.r0.gfc5876a
-pkgrel=2
+pkgname="obs-xdg-portal-git"
+pkgver=0.1.2.r21.g8430c46
+pkgrel=1
pkgdesc="OBS Studio plugin using the Desktop portal for Wayland & X11 screencasting"
arch=(x86_64)
-url="https://gitlab.gnome.org/feaneron/$_pkgname"
+url="https://gitlab.gnome.org/feaneron/obs-xdg-portal"
license=('GPL')
-depends=('obs-studio' 'gst-plugins-base-libs' 'xdg-desktop-portal')
+depends=('obs-studio-wayland' 'xdg-desktop-portal')
makedepends=('meson' 'git')
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-source=("git+$url"
- 'fix-timestamp.patch')
-sha256sums=('SKIP'
- 'e7fd7d3455a4b73cf750328d47ea3667d576106207a784ab2ce62c99eeb48813')
+conflicts=("${pkgname%%-git}")
+provides=("${pkgname%%-git}")
+source=("git+$url")
+sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd ${pkgname%%-git}
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$_pkgname"
- # https://gitlab.gnome.org/feaneron/obs-xdg-portal/-/merge_requests/4
- git apply "$srcdir/fix-timestamp.patch"
-}
-
build() {
- arch-meson "${_pkgname}" build
+ arch-meson ${pkgname%%-git} build
meson compile -C build
}