summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLolix2019-06-30 23:51:02 +0200
committerLolix2019-06-30 23:51:02 +0200
commit6d21cf1ad0ed32e22e35733332c2d55bbde4407c (patch)
treea071dd54534191f18c827f537d85d905ebfdd11b /PKGBUILD
parent60d70b41bcbd960af6aa71c475453808ec5a0c9b (diff)
downloadaur-6d21cf1ad0ed32e22e35733332c2d55bbde4407c.tar.gz
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83dd75f275d1..28f6db77300d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
-# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
# Contributor: Matt Harrison <matt@harrison.us.com>
# Contributor: scan
pkgname=obsidian-2-theme-git
-pkgver=2.3.1.r0.g674abd0
+pkgver=2.8.r2.gc2623c8
pkgrel=1
-pkgdesc="Obsidian 2 theme for Gnome 3.22+"
-arch=('any')
+pkgdesc="Obsidian 2 themes for Gnome 3.22+, all colors"
+arch=(any)
url="https://www.gnome-look.org/p/1173113/"
-license=('GPL3')
+license=(GPL3)
optdepends=('gnome-tweak-tool: A tool to customize advanced GNOME 3 options.')
options=(!strip)
-source=("${pkgname}::git+https://github.com/madmaxms/theme-obsidian-2.git"
- "https://github.com/madmaxms/theme-obsidian-2/archive/green.zip"
- "https://github.com/madmaxms/theme-obsidian-2/archive/amber.zip"
- "https://github.com/madmaxms/theme-obsidian-2/archive/red.zip")
+source=("theme-obsidian-2-blue::git+https://github.com/madmaxms/theme-obsidian-2.git"
+ "theme-obsidian-2-green::git+https://github.com/madmaxms/theme-obsidian-2#branch=green"
+ "theme-obsidian-2-amber::git+https://github.com/madmaxms/theme-obsidian-2#branch=amber"
+ "theme-obsidian-2-purple::git+https://github.com/madmaxms/theme-obsidian-2#branch=purple"
+ "theme-obsidian-2-red::git+https://github.com/madmaxms/theme-obsidian-2#branch=red")
md5sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
- cd ${pkgname}
+ cd "theme-obsidian-2-blue"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- install -d ${pkgdir}/usr/share/themes
- cp -r ${srcdir}/${pkgname}/Obsidian-2/ ${pkgdir}/usr/share/themes/Obsidian-2/
- cp -r ${srcdir}/theme-obsidian-2-{amber,green,red}/Obsidian* ${pkgdir}/usr/share/themes/
+ install -d "${pkgdir}/usr/share/themes"
+ cp -r ${srcdir}/theme-obsidian-2-{blue,amber,green,red,purple}/Obsidian* ${pkgdir}/usr/share/themes/
find ${pkgdir} -type f -exec chmod 644 {} \;
find ${pkgdir} -type d -exec chmod 755 {} \;