summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2016-02-06 04:43:42 +0100
committerJ5lx2016-02-06 04:43:42 +0100
commit1ae565485c2108ab421eb35f07f39cdc67bd3717 (patch)
treedd2ea029b752ab4ea4e01750a64bea009f91f127 /PKGBUILD
parentd7ac75fc8ce26a2987620177b0061dc843a5ac5c (diff)
downloadaur-1ae565485c2108ab421eb35f07f39cdc67bd3717.tar.gz
113.24.00-1: New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 816e918cb395..730145f3f1af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-core
-pkgver=113.00.00
+pkgver=113.24.00
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Industrial strength alternative to OCaml's standard library"
url="https://github.com/janestreet/core"
-depends=('ocaml' 'ocaml-bin_prot' 'camlp4' 'ocaml-comparelib' 'ocaml-core_kernel' 'ocaml-custom_printf' 'ocaml-enumerate' 'ocaml-fieldslib' 'ocaml-herelib' 'ocaml-pa_bench' 'ocaml-pa_ounit' 'ocaml-pa_structural_sexp' 'ocaml-pa_test' 'ocaml-pipebang' 'ocaml-sexplib' 'ocaml-variantslib')
+depends=('ocaml' 'ocaml-bin_prot' 'ocaml-core_kernel' 'ocaml-fieldslib' 'ocaml-ppx_assert' 'ocaml-ppx_bench' 'ocaml-ppx_driver' 'ocaml-ppx_expect' 'ocaml-ppx_inline_test' 'ocaml-ppx_jane' 'ocaml-sexplib' 'ocaml-typerep' 'ocaml-variantslib')
optdepends=('ocaml-utop: for coretop support')
-makedepends=('ocaml-findlib')
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
+makedepends=('ocaml-findlib' 'opam')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz"
+ "libdir.patch")
options=('!strip')
-md5sums=('9eca76d553f62f69f93cf9dcc70b0107')
+md5sums=('90aa987056d18d8be2600bc1dd0d71de'
+ '7f0a951f1ac87385272ea7a6dd58762a')
+
+prepare() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ patch -Np1 < "${srcdir}/libdir.patch"
+}
build() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
@@ -24,9 +32,5 @@ build() {
package() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
- install -Dm755 "corebuild" "${pkgdir}/usr/bin/corebuild"
- install -Dm755 "coretop" "${pkgdir}/usr/bin/coretop"
+ make install PREFIX="${pkgdir}/usr" LIBDIR="${pkgdir}$(ocamlc -where)"
}