summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Wojdyła2022-10-03 23:45:41 +0200
committerMichał Wojdyła2022-10-03 23:45:41 +0200
commita08f02b5c290a72763c796ac9102ff0e50251c44 (patch)
treee3f84af27bd17916edd3926db24d482b2463e1c4 /PKGBUILD
parent79c34f5d52201d49167e4517dff4e2218188e06c (diff)
downloadaur-ocaml-core_bench.tar.gz
update to 0.15.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89a4462ea380..3bf1d1847099 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-core_bench
-pkgver=0.14.0
+pkgver=0.15.0
pkgrel=1
epoch=1
pkgdesc="A micro-benchmarking library for ocaml"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/core_bench"
license=('Apache')
-depends=('ocaml' 'ocaml-core' 'ocaml-core_extended' 'ocaml-ppx_jane' 'ocaml-textutils' 'ocaml-migrate-parsetree' 'ocaml-ppxlib' 'ocaml-re')
+depends=('ocaml' 'ocaml-core' 'ocaml-core_unix' 'ocaml-ppx_compare' 'ocaml-ppx_fields_conv' 'ocaml-core_extended' 'ocaml-ppx_jane' 'ocaml-ppx_let' 'ocaml-ppx_sexp_conv' 'ocaml-textutils' 'ocaml-migrate-parsetree' 'ocaml-ppxlib' 'ocaml-re')
makedepends=('dune')
options=('!strip')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/core_bench-v${pkgver}.tar.gz")
-md5sums=('96c9241f978acbc3a6817b20b281996f')
+md5sums=('622be5cb12b8091c764caca053e1d368')
build() {
cd "${srcdir}/core_bench-v${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/core_bench-v${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}