summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2015-07-03 16:19:14 +0200
committerJ5lx2015-07-03 16:19:14 +0200
commit26c55595bff3cbae3f309f572f6c33792eed0399 (patch)
tree9c8cb55f2c746ef6ea0bc1de2488db3fe684e2a5 /PKGBUILD
downloadaur-26c55595bff3cbae3f309f572f6c33792eed0399.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbd7af4c1eee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-enumerate
+pkgver=111.08.00
+pkgrel=2
+license=('Apache')
+arch=('i686' 'x86_64')
+pkgdesc="Text output utilities"
+url="https://github.com/janestreet/enumerate"
+depends=('ocaml' 'camlp4' 'ocaml-type_conv')
+makedepends=('ocaml-findlib')
+source=("https://ocaml.janestreet.com/ocaml-core/${pkgver}/individual/${pkgname#ocaml-}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('2cb0ad1f4a7fc4c9fe1bf6d294be10ce')
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "$OCAMLFIND_DESTDIR"
+ DESTDIR="${pkgdir}" \
+ OCAMLFIND_DESTDIR="$OCAMLFIND_DESTDIR" \
+ make install
+}