summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2015-10-10 18:43:34 +0200
committerJ5lx2015-10-10 18:43:34 +0200
commitaa9b9646e0fd5bf5018500e9fd3932cc4bd4829a (patch)
tree6c5578b23dff72383163ec8e4fd524c8b4d9a7a6 /PKGBUILD
downloadaur-aa9b9646e0fd5bf5018500e9fd3932cc4bd4829a.tar.gz
0.2.1-1: Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9ee5628925d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-fdkaac
+pkgver=0.2.1
+pkgrel=1
+license=('GPL2')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml bingind for the fdk-aac library")
+url="https://github.com/savonet/ocaml-fdkaac"
+depends=('ocaml' 'libfdk-aac')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-fdkaac/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('fff652fa282b4954d2f504ca1c2a70e9')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}