summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 16:55:23 +0200
committerJakob Gahde2018-06-28 16:55:23 +0200
commitdf0a732367b73300df68ceba7229ea0e13e166a5 (patch)
treef34b752b0aa52bad9274f1868edb95e63ba77ead /PKGBUILD
downloadaur-df0a732367b73300df68ceba7229ea0e13e166a5.tar.gz
ocaml-jane-street-headers 0.11.0-1: New package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47220e92a13b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-jane-street-headers
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="Jane Street C header files"
+arch=('x86_64')
+url='https://github.com/janestreet/jane-street-headers'
+license=('Apache')
+depends=('ocaml')
+makedepends=('dune')
+options=('!strip')
+source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/jane-street-headers-v${pkgver}.tar.gz")
+md5sums=('13299bfe41f66f6a3f42cfaa015f4869')
+
+build() {
+ cd "${srcdir}/jane-street-headers-v${pkgver}"
+
+ jbuilder build
+}
+
+
+package() {
+ cd "${srcdir}/jane-street-headers-v${pkgver}"
+
+ mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+}