summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2015-10-10 21:00:17 +0200
committerJ5lx2015-10-10 21:00:17 +0200
commita4c3128944d5a2ebc03d29872e623ad5ea297334 (patch)
tree83f73668299a5af40570044581773443d7503c16 /PKGBUILD
downloadaur-a4c3128944d5a2ebc03d29872e623ad5ea297334.tar.gz
0.1.5-1: Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd7854a28d4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-ladspa
+pkgver=0.1.5
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml bindings for LADSPA plugins")
+url="https://github.com/savonet/ocaml-ladspa"
+depends=('ocaml')
+makedepends=('ocaml-findlib' 'ladspa')
+source=("https://github.com/savonet/ocaml-ladspa/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('ae66337eb15dbbf0f432016e79db7267')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}