summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2015-10-10 18:09:04 +0200
committerJ5lx2015-10-10 18:09:04 +0200
commitb671a0831014d15787d4a409cf48cb5edf09a226 (patch)
treef67e6ddeeab6b249dec3c315d97fcda8d90c8c09 /PKGBUILD
downloadaur-b671a0831014d15787d4a409cf48cb5edf09a226.tar.gz
0.3.3-1: Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d43368cb4b7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-lame
+pkgver=0.3.3
+pkgrel=1
+license=('GPL2')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml bindings to the LAME mp3 encoder")
+url="https://github.com/savonet/ocaml-lame"
+depends=('ocaml' 'lame')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-lame/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('a1585835f94f8d459157263ed2aaede3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}