summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-05 10:22:27 +0200
committerDaniel Peukert2020-06-05 10:22:27 +0200
commitea05071cb7d8674f9ec03c1a596812618ec611a7 (patch)
treefe4332678d278231459b1afb42a07990ff986f24 /PKGBUILD
parent1b62953588a2c1f59d9ea6f4a221528cdf32ba22 (diff)
downloadaur-ea05071cb7d8674f9ec03c1a596812618ec611a7.tar.gz
Removed a test that breaks for some people from ocaml-lwt
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65e352c4bb1c..a7279ef66710 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_projectname='lwt'
pkgname="ocaml-$_projectname"
pkgver='5.3.0'
-pkgrel='2'
+pkgrel='3'
pkgdesc='A library for cooperative threads in OCaml'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocsigen/lwt"
@@ -19,6 +19,13 @@ sha256sums=('38ce928378a07b685f4606b60cbe37c26ef93ccb3e808c218e7d34ece9e659ad')
_sourcedirectory="$_projectname-$pkgver"
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+ # this test breaks for some people but not for others
+ # see comments from oriba, crave and pha-qu on the AUR page
+ sed -i '/test_mcast "mcast-join-loop"/d' 'test/unix/test_mcast.ml'
+}
+
build() {
cd "$srcdir/$_sourcedirectory/"
LWT_DISCOVER_ARGUMENTS='--use-libev true' dune build -p "$_projectname,${_projectname}_ppx,${_projectname}_react" --verbose